Calibration Data

Home Forums AR Sandbox Forum Calibration Data

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #115436
    jkeller
    Participant

    When I run…

    sudo /usr/local/bin/KinectUtil getCalib 0
    terminate called after throwing an instance of ‘std::runtime_error’
    what(): USB::Device::getSerialNumber: Error while querying serial number string
    Aborted (core dumped)

    If I reboot, it will run once, start to download calibration and just sits there. Any subsequent tries gives me the error above. Any ideas?

    #115481
    Oliver Kreylos
    Keymaster

    When you reboot and run sudo /usr/local/bin/KinectUtil getCalib 0, does it print a bunch of stuff followed by “Writing full intrinsic camera parameters to …” and then sit there, or does it hang before that?

    If it prints and then hangs, press Ctrl-C to shut it down, then proceed as normal. This sometimes happened with older versions of the Kinect package. It should no longer happen with Kinect-3.5.

    If it hangs before printing, you’ll have a bigger issue; check the forum post on “USB problems with Kinect”.

    #115597
    jkeller
    Participant

    This is what happens

    jkeller@jkeller-LINUXMINT ~ $ sudo /usr/local/bin/KinectUtil getCalib 0
    [sudo] password for jkeller:
    Downloading factory calibration data for Kinect A00364W00767203A…

    Just sits there. Could this possibly be an issue with the 3rd party adapter to connect it to the PC? I’m using model 1414.

    #115598
    jkeller
    Participant

    The other thing, when I run lsusb, the Kinect shows up

    Bus 003 Device 118: ID 045e:02ae Microsoft Corp. Xbox NUI Camera
    Bus 003 Device 116: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
    Bus 003 Device 117: ID 045e:02ad Microsoft Corp. Xbox NUI Audio

    If I try other usb ports, one or two of those will show up, and I run the lsusb command immediately after, the audio or motor (or both) will disappear. Trying to narrow this down as I had this working with the Kinect V2. I have a feeling it could be the 3rd party adapter.

    • This reply was modified 2 years, 6 months ago by jkeller.
    #115607
    jkeller
    Participant

    Tested Kinect with adapter on Xbox 360 and works fine. Stumped.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Comments are closed.