caught exceptions with RawKinectViewer and SARndbox

Home Forums AR Sandbox Forum caught exceptions with RawKinectViewer and SARndbox

This topic contains 5 replies, has 4 voices, and was last updated by  ninjaneerstudios 3 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #100694

    Dennis
    Participant

    Hi again,

    unfortunately I still have problems getting the sandbox running.

    Mostly during I start one of the programs (like RawKinectViewer or Sandbox) I receive one of the following messages:

    “Caught exception USB::Device::setAlternateSetting: Interface 0 does not have alternate setting 1”

    or sometimes also this one

    “Caught exception Kinect::Camera::sendMessage: Protocol error while sending message 0”

    It seems, that the programs will not work 100% properly with the Kinect for Windows Camera (Model 1517), will it?

    Often it will work for “one more call” if I reset the Camera (with KinectUtil) but not every time (sometimes the reset will end too fast to be successful).

    Do someone have any ideas, what’s wrong with the system? I use an Ubuntu 14.04.1 LTS (with current updates), the current versions of the software packages and the 1517 model of the Kinect camera.

    Thanks in advance,
    Dennis

    #100696

    Oliver Kreylos
    Keymaster

    That’s unfortunate. While it’s true that all versions of the original Kinect (-for-Xbox 1414 and 1473 and -for-Windows 1517) are not 100% reliable, we’re typically only seeing issues very rarely. I haven’t noticed Kinect-for-Windows devices being less reliable than -for-Xbox ones in general.

    When issues do occur (such as error messages, or the depth map being completely flat or non-existent), it’s usually sufficient to restart the application that was using or trying to use the Kinect. If that doesn’t help, KinectUtil reset all typically does the trick.

    If you’re seeing problems that often, there might be a problem with your specific Kinect device, or with the USB port into which it’s plugged, or your entire USB subsystem. If your Kinect is currently plugged into a USB 3 port, try using a USB 2 port. While our software fully supports Kinect over USB 3, USB 3 support in the Linux kernel is still a bit lacking, and Ubuntu 14.04 uses a somewhat older kernel.

    If you’re already on USB 2, try a different plug, ideally on a different bus (front-facing and back-facing ports on a typical tower PC are usually on different buses). If all that doesn’t help, try the Kinect software on a different PC if you have one, and if that helps but you want to keep using the one you currently use, try to find a cheap USB 2 or USB 3 PCI expansion card ($5-$20) and put that into the PC and the Kinect into it.

    #100797

    Dennis
    Participant

    Hi Oliver,

    I want you to get some feedback from your tips.

    I solved the problem by installing an USB 2.0 controller card and connecting the camera on one of its ports. With this the problem vanished and all tools are running without any exceptions.

    Thanks for your help. I appreciate it.

    Greetings,
    Dennis

    #100799

    Oliver Kreylos
    Keymaster

    OK, then you had a broken USB host controller. That happens. The Kinect sends a lot of data over USB, and controllers that seem to work fine for keyboards or mice or webcams etc. might buckle under the load.

    #101247

    kyarosh
    Participant

    All, I just wanted to share that I was also having these same USB issues with a Brand new MSI motherboard as of the time of this message posting. My challenge was that my new motherboard and case is of the ITX form factor and I don’t have any more slots to add an additional cheap USB controller – the gigantic NVidia GeForce GTX 970 hogged all the slot space. However, the key was to get the Kinect camera on its own USB 2.0 bus. There were USB 2.0 and USB 3.0 connectors on the front and back of the case. I connected keyboard and mouse to USB 3.0 and made sure Kinect was the only thing on USB 2.0 and verified that with lsusb. Once I isolated the Kinect on USB 2.0, voilà, no usb errors or exceptions popping up. So with this it cannot be emphasized enough – the Kinect should be on its own USB 2.0 bus (NOT plugged into a usb hub or mixed with mouse and keyboard). Hope this helps others and thanks again Dr. Kreylos!

    #101270

    ninjaneerstudios
    Participant

    Good morning Everyone,

    We were getting this MSG when trying to get our Kinect to work (model: 1414):

    terminate called after throwing an instance of ‘std::runtime_error’
    what(): Kinect::Camera::Camera: Less than 0 Kinect camera devices detected
    Aborted

    The light on the Kinect was blinking sporadically and would go off. The solution that worked for us was to go buy a PCI Express USB 3.0 Card that is also powered from your PSU. The problem is that your normal USB ports and the XBOX Kinect AC Adapter are not enough power. After this, VRui detects the kinect every time. We tried several more kinect’s just to make sure it wasn’t a fluke.

    I will list our setup below:

    CPU: i7 Hasswell
    GPU: 970 GTX CeForce Nvidia
    PSU: 750W
    HDD: 120gig SSD
    RAM: 8 gig
    MB: Asus Sabertooth z87 Motherboard
    OS: Linux Mint with Mate (with all updates) I believe the new one is 17.2 codename Rafaela
    USB 3.0 PCI Express Cars that can also be powered by the PSU
    Xbox Kinect: Model# 1414

    The card we bought is this one Insignia PCI Express USB 3.0 Card
    Here is the link to copy and paste if the one above doesn’t work ( http://www.bestbuy.com/site/insignia-2-port-usb-3-0-pci-express-interface-card-silver/5621006.p?id=1219144863553&skuId=5621006 ). We got it from Best Buy. If you look at the picture of the card, at the back of the card you’ll see where the power connector will plug in. It’s the same type of power plug that is/was used for the old floppy drives. The power connector should come in the box.

    If you’re getting the same error msg as above, this should fix your issue. The green light on the front needs to be a constant, steady, green blinking light not a sporadic one that comes and goes. When we would type in the command to locate all connected USB devices, it would find only the Kinect motor, then motor and camera, then none and kept doing this until we installed this card. We had it running for more than 10min to make sure it didn’t drop out.

    I think it needs 700mA or more, but don’t quote me.

    Hope this helps, it did for us.

    Joe R
    Director
    Ninjaneer Studios

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Comments are closed.