Common Issues (READ THIS FIRST!)

Home Forums AR Sandbox Forum Common Issues (READ THIS FIRST!)

Tagged: , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , ,

Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
  • #100752
    Oliver Kreylos
    • The AR Sandbox application does not run properly from inside a virtual machine.
    • We can no longer recommend Mac OS X as a base operating system for the AR Sandbox. See this thread for complete instructions on how to set up a Linux Mint-based AR Sandbox starting from a blank PC.
    • Do not attempt intrinsic Kinect camera calibration on your first build. The AR Sandbox software can cope with most issues stemming from mismatching calibration data. Only if you notice unsatisfactory behavior such as noticeable projection mismatches or non-level contour lines perform all the calibration steps in sequence.
    • The recommended BenQ MX631ST projector has an automatic keystone correction feature that uses accelerometers to measure the projector’s tilt angle, and then transforms the image to project onto a vertical screen without distortion. This goes haywire when projecting down onto a sandbox, so this feature (“Auto Keystone”) must be disabled via the projector’s on-screen menu. It is also ideal to reset the projectors keystone correction value to zero, and check periodically that it stays at zero.
    • If the Kinect software (KinectUtil, RawKinectViewer, KinectViewer) has trouble connecting to your Kinect device (errors such as “terminate called after throwing an instance of ‘std::runtime_error what(): Kinect::Camera::Camera: Less than 0 Kinect camera devices detected”), or if the green LED on the Kinect does not blink slowly and steadily, check if your Kinect is plugged into a USB 2.0 port. If using USB 2.0 does not help, or your computer only has USB 3.0 ports, you might have to buy a USB 3.0 extension card like the one mentioned in this thread.
    • If you receive “GL Error: …” while running any of the Kinect or Sandbox applications, check that you have the proper vendor-supplied drivers for your graphics card installed. The AR Sandbox application will run poorly in software-emulated OpenGL mode.
    • The order of box corner points in the video for AR Sandbox calibration step 5 is wrong. Instead of collecting in counter-clockwise order, collect in order lower-left, lower-right, upper-left, upper-right. If you already collected corner points in the wrong order, swap the last two lines of BoxLayout.txt. Update: The 2.8-001 version of the Kinect package has a new tool in RawKinectViewer that greatly simplifies this calibration step.
    • The CalibrateProjector utility and the AR Sandbox main application must be run at the exact same window position and size for calibration to match, ideally in full-screen mode without window borders or desktop panels. Refer to this thread for how to set up full-screen mode.
    • After collecting the first set of calibration tie points in sandbox calibration step 7, ensure that the calibration is good by moving the target disc all over the sandbox area and checking that the red crosshairs track it well.
    • The SARndbox application must be run with the -fpv command line argument or it will not use the projector calibration matrix collected in sandbox calibration step 7.
    • This topic was modified 6 years, 5 months ago by Oliver Kreylos.
    • This topic was modified 6 years, 5 months ago by Oliver Kreylos.
    • This topic was modified 6 years, 5 months ago by Oliver Kreylos.
    • This topic was modified 6 years, 5 months ago by Oliver Kreylos.
    • This topic was modified 6 years, 5 months ago by Oliver Kreylos.
    • This topic was modified 6 years, 4 months ago by Oliver Kreylos.
    • This topic was modified 6 years, 4 months ago by Oliver Kreylos.
    • This topic was modified 5 years, 9 months ago by Oliver Kreylos.
    • This topic was modified 5 years, 8 months ago by Oliver Kreylos.
    • This topic was modified 4 years, 8 months ago by Oliver Kreylos. Reason: Removed some issues that have been fixed in software
    • This topic was modified 4 years, 7 months ago by Oliver Kreylos. Reason: Changed link for full-screen setup to new post
    • This topic was modified 1 year, 7 months ago by mbyikilmaz.

    I am attempting to complete these steps on a Raspberry Pi 2 with QUAD Core Broadcom BCM2836 CPU and 1GB RAM. The device came with an 8GB micro SD card. I am also using the latese Kinect device that came out in Winter of 2014. I found a forum on here where someone stated they were able to run these steps successfully on a Raspberry Pi and I commented on that forum as well. Just thought I would post here to see if there are any suggestions for the error I am getting.

    I started with Step 4 as I am running on Raspbarian (as mentioned in my previous post) and am NOT using a dedicated graphics card. I saw no reason to complete Step 3.

    After issuing the commands in the first part of Step 4, I receive a GL error. I know that this error is mentioned above:

    If you receive “GL Error: …” while running any of the Kinect or Sandbox applications, check that you have the proper vendor-supplied drivers for your graphics card installed. The AR Sandbox application will run poorly in software-emulated OpenGL mode.

    I am not using any dedicated graphics card, just the Raspberry Pi, so I am not sure what to do when receiving this error. Here is the specific error:

    Caught exception GLContext: Unable to open display default while initializing rendering window 0
    Caught exception Vrui::startDisplay: Could not create all rendering windows while initializing renddering windows

    This error was thrown after the response:
    Running ShowEarthModel application. Press Esc or close window to exit.

    No window popped up with a spinning globe as mentioned in the Complete Installation Instructions. I assume the error was thrown because the a window tried to render and was unable to do so. I am at a loss as what to do next?

    Thank you,


    @kmattr2050 did you have any luck with the Pi? Judging from the high requirements of the graphics needed this project, I’m skeptical…

    I’d love to hear how you made out!



    no, I did not have any luck with the RaspberryPiII. I thought the same as you about the graphics being to demanding for the RP2, but I was a little wishful when I saw another post on this forum form a user who stated that they were successful putting this program on one. I responded to the user’s post on this forum, but they never responded back so I moved on to another system.

    The problem I am facing now is a new error. When I run the main Sandbox application I receive this error:

    Cannot fix projector view due to exception IO::StandardFile: Unable to open file /home/sand/src/SARndbox-1.5-001/etc/SARndbox-1.5/ProjectorMatrix.dat for reading due to error 2
    0.155481 x 0.15066

    Problem is, I cannot find the file ‘ProjectorMatrix.dat’ in any directory I have on the machine.

    I am using a system my school provided to me as setting the AR Sandbox up is a project I have for this semester. Below are the specs for the machine given to me:

    Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
    Memory : 2047MB (653MB used)
    Operating System : Ubuntu 15.10
    User Name : sand (Sand)
    Date/Time : Sun 08 Nov 2015 05:20:01 PM EST
    Resolution : 1024×768 pixels
    OpenGL Renderer : Unknown
    X11 Vendor : The X.Org Foundation
    Audio Adapter : HDA-Intel – HDA NVidia

    Operating System
    Kernel : Linux 4.2.0-16-generic (x86_64)
    Compiled : #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015
    C Library : Unknown
    Default C Compiler : GNU C Compiler version 5.2.1 20151010 (Ubuntu 5.2.1-22ubuntu2)
    Distribution : Ubuntu 15.10

    Oliver Kreylos

    The ProjectorMatrix.dat file is created by the projector calibration step (step 10 in the complete installation instructions).

    You can run the AR Sandbox without projector calibration by leaving off the -fpv command line parameter, but then you will get a regular 3D rendering of the scanned sand surface which will not match the physical sand surface (but which you can pan/rotate/zoom using mouse and keyboard).

    Oliver Kreylos

    Raspberry Pi natively only supports OpenGL ES (OpenGL for Embedded Systems). The AR Sandbox software is not compatible with OpenGL ES. You can in principle run the AR Sandbox on a Raspberry Pi by installing the Mesa OpenGL library, but performance will be very poor as Mesa emulates OpenGL in software running on the Pi’s main CPU, which is very weak.


    After what appears to be a successful installation and calibration, I launch the program and am greeted by a black screen with a red rectangle in the lower left hand corner. This happens when water is turned on [./bin/SARndbox -uhm -fpv] and when water is turned off [./bin/SARndbox-1.6 -ws 0.0 0 -fpv].

    I’ve searched the forums, and to the best of my knowledge followed the instructions. My guess is that there is an issue with the graphics card. The computer does not have a Nvidia graphics card.

    Please advise. I’ve included the specs of the system I am using below.

    White Macbook (2008) Running Linux Mint 17.3 Rosa
    Kernel Linux 3.19.0-32-generic x86-64
    MATE 1.12.0
    Memory 1.9 GiB
    Processor Intel Core 2 Duo CPU T8300 @ 2.4 GHz * 2

    $ lspci | grep “VGA”
    00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)


    Oliver explains my problem on this page:


    After I do step 5 and collect the points to calibrate the sandbox, it tells me that there is an error and that there a negative points. Any idea how to fix this?


    HI, this is most likely because of the wrong corner point collection sequence, there was an inconsistency between the documented instructions and the video. Its a backwards Z pattern not a clockwise process.

    I won’t repeat it here at risk of yet another source of confusion – its elsewhere on the forum and correct on the video.



    For error:
    “Caught exception GLContext: GLX extension not supported on display :0 while initializing rendering window 0
    Caught exception Vrui::startDisplay: Could not create all rendering windows while initializing rendering windows”

    You can try to solve this error by installing “Mesa”(OpenGL) for Linux Mint before step 1 to install the arsandbox software. Open the terminal and insert the following lines, one at a time:

    sudo apt-get update
    sudo apt-get install freeglut3
    sudo apt-get install freeglut3-dev
    sudo apt-get install binutils-gold
    sudo apt-get install g++ cmake
    sudo apt-get install libglew-dev
    sudo apt-get install g++
    sudo apt-get install mesa-common-dev
    sudo apt-get install mesa-common-dev
    sudo apt-get install libglew1.5-dev libglm-dev

    After your development libraries have been installed to get information about the OpenGL and GLX implementations running on a particular X display.
    Type / Copy / Paste:
    glxinfo | Grep OpenGL

    And then proceed to step 1 of the Arsandbox installation. The GLContext error should no longer occur.


    Greetings AR Sandbox Community – We have an inexpensive lab computer that we have been using as a prototype for our AR Sandbox that until recently has been running well by simply turning off the water simulation and just running the contour lines (works great for physical geography). However, we tried setting it up for a lab and are getting an odd screen on the last step of the instructions (./bin/SARndbox -uhm -fpv). It’s a light blue screen covered in tiny circles. The contour lines never actually draw and nothing on the screen updates when you move the sand. We’ve reinstalled the machine with Mint and reinstalled all the software. We’ve also tested with a Kinect that we know works and still get the same error. Link to image.

    Any recommendations?

    Thanks – Mike


    Greetings AR sandboxers!

    We’ve recently installed a whole pre-fab setup from System76/Diversified Woodcrafts.

    Everything is working, the only exception being the water flow simulation which is extremely laggy. Looking at other web resources it seems the SARndbox programming may be running off the wrong graphics driver, even though the “correct” one is hidden somewhere in the files.

    Before I get too deep down the rabbit hole and start installing/uninstalling new drivers, does anyone have any insight on this issue?

    Oliver Kreylos


    glxinfo | grep vendor

    The output should be like

    server glx vendor string: NVIDIA Corporation
    client glx vendor string: NVIDIA Corporation
    OpenGL vendor string: NVIDIA Corporation

    If it’s not, you’re running off the wrong graphics card or driver.


    Off the subject perhaps.
    I just updated my ARS and also put everything on a laptop to make it mobile for moving it from classroom to classroom. When I moved it over from the original setup I used the calibration files from the old computer because the projector and kinect were not moved. It all seems to work great and it even allows me to do many of the post setup tweaks, however I cannot get it to rain by creating a cloud. I can use the set keys and rain everywhere but and every now and then it somehow sees my arm or something in the right place and rains slightly but not as consistently and as much as it should. I seems I cannot get it to do rain with out the keys or the very rare occasion. Can you tell me where I can look to solve this? I know I should just re-do the calibration from the start, but moving all the sand makes that route unappealing. Could you let me know your opinion?

    By the way, Thank you and all those that produced this project and the wonderful instructions. It made me look like a genius. Even if that to was only augmented reality.


Viewing 15 posts - 1 through 15 (of 30 total)
  • You must be logged in to reply to this topic.

Comments are closed.