Complete Installation Instructions

Home Forums AR Sandbox Forum Complete Installation Instructions

This topic contains 110 replies, has 58 voices, and was last updated by  yahoosupport4 3 days, 17 hours ago.

Viewing 15 posts - 16 through 30 (of 110 total)
  • Author
  • #100890


    14.04.2 The latest on the download site.



    Hi Oliver – my version of Ubuntu 14.04 LTS



    Must be a hardware-ish issue on my end. I just installed the Vrui software with no hiccups on my 3+year old laptop (Ubu 14.04) with no problem.



    I’m having this problem too. My laptop is Lenovo Y400 with NVIDIA GeForce GT 650M

    fathahnoor@Lenovo-IdeaPad-Y400:~$ bash
    Please enter your password to install Vrui's prerequisite packages
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Note, selecting 'libpng12-dev' instead of 'libpng-dev'
    Note, selecting 'libtiff5-dev' instead of 'libtiff-dev'
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     libcheese-gtk23 : Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                       Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
     libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
                  Depends: gstreamer1.0-clutter but it is not going to be installed
     libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                        Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Problem while downloading prerequisite packages; please fix the issue and try again
    • This reply was modified 3 years ago by  fathahnoor.


    I too was having those same dependency errors. I did a fresh install of Ubuntu 14.04.2 on a HP Z400 workstation. I am not sure if this is the best way to do this but I did this and it looks like it has worked so far.

    sudo apt-get remove libcheese*
    sudo apt-get remove libclutter*


    Oliver Kreylos

    This appears to be a packaging bug in Ubuntu 14.04.2. Until they fix it, you’ll have to fix the dependencies manually or use the previous release, 14.04.1.



    Oh on second thought don’t do it exactly like I did. It must break something else because not when I reboot it does not load up at all.



    I change it to 14.04.1 and it working now, thanks! ­čÖé



    So I now have the sandbox working. Calibration so far seems decent. Will probably do a few more times to fine-tune.

    So the problem I still have is poor water simulation performance.

    The computation/rendering of the water on top of sand topography is slow and jerky.

    I’m running Ubuntu 14.04.1 (that fixed previous issues).
    CPU: 4th gen i7
    RAM: 24GB
    GPU: NVidia 980GTX




    I am getting the following error after “bash”. Does anyone have any suggestions? I am using Linux Mint 17.1 Mata

    “Creating pkg-config meta data file…
    Linking /home/zephyr/src/Vrui-3.1-003/lib/x86_64-linux-gnu/…
    Linking /home/zephyr/src/Vrui-3.1-003/lib/x86_64-linux-gnu/…
    Linking /home/zephyr/src/Vrui-3.1-003/lib/x86_64-linux-gnu/…
    /usr/bin/ld: cannot find -lGL
    collect2: error: ld returned 1 exit status
    make: *** [/home/zephyr/src/Vrui-3.1-003/lib/x86_64-linux-gnu/] Error 1
    make: *** Waiting for unfinished jobs….
    Build unsuccessful; please fix any reported errors and try again”




    your machine should be more than capable to do the computation. I had a very slow water performance as well, with an nvidia gtx770 card. try one of the other nvidia drivers. that solved it for me.

    Cheers, Manu



    The entire installation went smoothly as your videos shows. The only problem is in the las step 11. When I try to run AR Sandbox application in terminal window I get this:

    0.155481 x 0.15066
    segmentation fault

    And ARSandbox doesn’t want to start. It is like nothing heppend.. ­čÖü can anyone help me ?



    Oliver Kreylos

    Most probably a driver problem. Use the “Additional Drivers” control panel to install the binary Nvidia driver, and that should fix it.


    Oliver Kreylos

    Strange. Did you install the binary Nvidia driver via “Driver Manager,” as in step 2 and shown in the video?

    Also, please post the output of the following command:

    find /usr/lib* -name "libGL*"

    Oliver Kreylos

    RawKinectViewer, KinectViewer, and CalibrateProjector all worked fine?

    Please run the sandbox as

    SARndbox -fpv -ws 0.0 0

    to temporarily disable water simulation and see if that works.

Viewing 15 posts - 16 through 30 (of 110 total)

You must be logged in to reply to this topic.