Complete Installation Instructions

Home Forums AR Sandbox Forum Complete Installation Instructions

This topic contains 110 replies, has 58 voices, and was last updated by  yahoosupport4 3 days, 17 hours ago.

Viewing 15 posts - 61 through 75 (of 110 total)
  • Author
  • #101733

    Oliver Kreylos

    Which Linux distribution and which exact version are you using?



    Pulling my hair out using Ubuntu 14 and linux mint got various combinations of all the errors mentioned above. Last chance – fresh pc, fresh install mint

    serendipity@Serendipity-AR-Sandbox ~ $ bash
    Please enter your password to install Vrui’s prerequisite packages
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘libpng12-dev’ instead of ‘libpng-dev’
    Note, selecting ‘libtiff5-dev’ instead of ‘libtiff-dev’
    Some packages could not be installed. This may mean that you have

    The following packages have unmet dependencies.
    build-essential : Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed

    serendipity@Serendipity-AR-Sandbox ~ $ sudo apt-get install dpkg-dev
    Reading package lists… Done

    The following packages have unmet dependencies.
    dpkg-dev : Depends: libdpkg-perl (= 1.17.5ubuntu5) but 1.17.5ubuntu5.4 is to be installed
    E: Unable to correct problems, you have held broken packages.

    serendipity@Serendipity-AR-Sandbox ~ $ sudo apt-get install libdpkg-perl
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Suggested packages:
    The following packages will be upgraded:
    1 to upgrade, 0 to newly install, 0 to remove and 347 not to upgrade.
    Need to get 179 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    Get:1 trusty-updates/main libdpkg-perl all 1.17.5ubuntu5.5 [179 kB]
    Fetched 179 kB in 1s (148 kB/s)
    (Reading database … 173124 files and directories currently installed.)
    Preparing to unpack …/libdpkg-perl_1.17.5ubuntu5.5_all.deb …
    Unpacking libdpkg-perl (1.17.5ubuntu5.5) over (1.17.5ubuntu5.4) …
    Processing triggers for man-db ( …
    Setting up libdpkg-perl (1.17.5ubuntu5.5) …

    After installing libdpkg-perl

    serendipity@Serendipity-AR-Sandbox ~ $ bash

    Success everything ran fine and spinning globe was a welcome sight

    so for me sudo apt-get install libdpkg-perl was the key.



    Hi Oliver, I have run into a new roadblock. I got my Sandbox up and running and it was a big hit at GIS day!! However, I was using my desktop computer to run it. Now I am trying to have a more permanent installation and want to run it on a Raspberry Pi2 (without the water) so people at my office can play with it. I am using Ubuntu Mate image on my Pi and everything seems to install correctly but when I try to run the sandbox I get an error that says:

    Cannot fix projector view due to exception IO::StandardFile: Unable to open file
    /home/matt/src/SARndbox-1.6/ProjectorMatrix.dat for reading due to error 2
    0.152457 x 0.156846

    Any ideas? Or am I just wasting my time try to get a Pi to do this?



    Hi Oliver,

    I’m still trying to get our sandbox up and running. It was working fine up until recently with the exception of trying to get the button to work to drain the water. Now however the sandbox software when running seems to lock up. When I close the software I get “Exception caught: USBDevice::writeControl: Error while writing”. I tried Googling the error and I came across the driver you had written for the Kinect and found where the error is being thrown in the code, but I’m not entirely sure what would be causing it.

    The laptop the Kinect is being run on unfortunately only has USB 3.0 ports. Not sure if this is going to be a major issue or not or if the driver that was written for the Kinect is only compatible across USB 2.0. I ran a lsusb and it does show with the Kinect plugged in it is on Bus:003 DevID: 001 and the root hub that is on Bus:003 DevID: 001 is Linux root 2.0 hub.

    Any assistance you could possibly provide would be awesome.



    Oliver Kreylos

    for me sudo apt-get install libdpkg-perl was the key.

    Thank you for figuring that out, and reporting back. I can add that package to the list in the script.


    Oliver Kreylos

    That appears to be a configuration problem. SARndbox is looking for the projector calibration matrix in the wrong place. You can test this by copying ProjectorMatrix.dat from /home/matt/src/SARndbox-1.6/etc/SARndbox-1.6/ProjectorMatrix.dat (where it should be) to /home/matt/src/SARndbox-1.6/ProjectorMatrix.dat (where SARndbox seems to be looking for it).

    But it shouldn’t be looking there. Somehow your SARndbox source package seems to have gotten messed up. It’s probably best to back up your configuration files (BoxLayout.txt, ProjectorMatrix.dat), remove the entire SARndbox-1.6 directory, and download a fresh tarball. Then copy the config files back where they really belong, and you should be good.

    The Pi2 is going to be marginal for running an AR Sandbox even without water, but this problem has nothing to do with the Pi.


    Oliver Kreylos

    The Kinect software works fine over USB 3.0, but the problem is that some USB 3.0 host controllers are poorly supported in the Linux kernel itself. Basically, there are a lot of broken USB 3.0 controllers on the market that require “quirks” to make them work, and those are only implemented in secret custom drivers, typically only for Windows. Unfortunately, your laptop might have one of those USB chips.

    You can find out which controller chip you have via lspci | grep "USB 3.0". The ones known to be good are by NEC or Renesas, chip ID uPD720200 or similar.


    Ross Heeb

    After I ran ~/Vrui-3.1/bin/XBackground it fit the sandbox. Then when I ran ./bin/CalibrateProjector -s 1024 768 I got bash: ./bin/CalibrateProjector: No such file or directory. I am using a BenQ projector. Can you help me.


    Oliver Kreylos

    Did you cd into the SARndbox directory before trying to run ./bin/CalibrateProjector? It should go like this:

    $ cd ~/src/SARndbox-1.6
    $ ./bin/CalibrateProjector -s 1024 768

    If that still doesn’t work, do

    $ ls ~/src/SARndbox-1.6

    and check that the d, o, and bin directories exist. If not, run

    $ make

    If you run into further problems, please start a new thread in the main forum. This thread is becoming hard to manage.



    That sounds like a great capability to add!



    Sorry here is the link to the picture



    I’m planning on starting a sandbox very soon so I’m watching this forum to get familiar with the process and the pitfalls.

    A bit “THANK YOU” to Oliver for all of the support he’s been giving for this project!





    Problem solved – video card



    Hello Oliver,

    I am beginning to build a sandbox for my senior design class at the University of Illinois, Urbana-Champaign. I am a beginner with linux and am in the process with installing mint on my windows 7 machine. I have been able to boot my computer from a usb and install linux, but when I attempt to reboot the computer to complete the installation I am unable to get back into the os I installed. I have been taking the usb out and pressing enter like you say, but the computer shuts down and and reboots in its normal windows process. Is there any specific solution to this that you would be able to help me with?


Viewing 15 posts - 61 through 75 (of 110 total)

You must be logged in to reply to this topic.