Dependency problems in Ubuntu-14.04.2

Home Forums AR Sandbox Forum Dependency problems in Ubuntu-14.04.2

This topic contains 3 replies, has 3 voices, and was last updated by  Oliver Kreylos 3 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #100905

    Oliver Kreylos
    Keymaster

    There is a packaging problem in Ubuntu-14.04.2 that leads to errors when running Vrui’s Build-Ubuntu.sh script. Until this gets sorted out by Canonical, I recommend using the previous release, Ubuntu-14.04.1.

    The problem can be fixed manually by running this command before running Build-Ubuntu.sh:

    sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

    #100907

    Stan
    Participant

    So I just ran that and I still get this;

    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
    Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Problem while downloading prerequisite packages; please fix the issue and try again

    #100931

    Rickshaw
    Participant

    I believe the link to the old release of 14.04.1 has changed to:
    http://old-releases.ubuntu.com/releases/14.04.1/

    #100943

    Oliver Kreylos
    Keymaster

    Thanks; I added the link to the “complete instructions” thread.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.