Failure at step 12

Home Forums AR Sandbox Forum Failure at step 12

This topic contains 2 replies, has 2 voices, and was last updated by  M.Hacker 1 month, 4 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #118516

    M.Hacker
    Participant

    [Second attempt to post this, first was a few hours ago.]

    I’ve tried twice now to setup the software for a sandbox. The computer is the same but this time around I removed and re-installed the video drivers and re-installed all of the sandbox related software as well. I can get through every install step in what seems like a successful manor but when I start the software at the end (step 12) I get slowly updating bits of pixels here and there with a sort of relation to what’s in the field of view but not a real image or contour line.

    ‘RawKinectViewer -compress 0’ looks like this (normal I think):
    RawKinectViewer image

    but after an apparently reasonable calibration ‘./bin/SARndbox -uhm -fpv -ws 0 0.0’ looks like:
    SARndbox image That photo is from the window on the main computer but moving the window to the projector and full sizing doesn’t change anything.

    And ideas? If I enable water the image doesn’t change but I do get lots of timeout messages. It feel like the OpenGL process isn’t working right and or is super slow but as far as I can tell all the pieces are correct. Is it normal for glxinfo to have both the hardware renderer info and the “OpenGL ES” info? Details below.

    Computer hardware Dell 7010 with an eVGA nVidia GO107GL card I bought. Selected output from various checks below.

    ‘lspci -vnn | grep -i vga’
    NVIDIA Corporation GP107 [GeForce GTX 1050 3GB] [10de:1c83]

    Video driver from ppa.launchpad.net installed via apt-get version 415.27

    ‘glxinfo | grep OpenGL’ (selected lines)
    vendor string: NVIDIA Corporation
    renderer strong: GeForce 1050/PCIe/SSE2
    core profile version string: 4.6.0 NVIDIA 415.27
    core profile context flags: (none)
    core profile profile mask: core profile
    core profile extensions: [blank]
    extensions: [blank]
    ES profile version string: OpenGL ES 3.2 NVIDIA 415.27
    ES profile shading language version string: OpenGL Es GLSL ES 3.20
    ES profile extensions: [blank]

    OS version: Linux Mint 19 Tara

    #118534

    steekli
    Participant

    lost image

    #118542

    M.Hacker
    Participant

    Here are links to the photos:

    https://drive.google.com/open?id=1wXLBirZYAHAz60Wqw3Vttx-ExVo1QZtX
    https://drive.google.com/open?id=1T8yWBxzyrRv5F-IFHNo7akQmU7jezWC7

    I also built another system from scratch on a new box (Dell 9020) and again it looks like RawKinectViewer works as expected, after I collect 12 calibration points it looks like the calibration is basically right (red lines cross on target disk and follow it around).

    But when I run: SARndbox -uhm -ws 0.0 0 -fpv I get output that looks like the second link about.

    If I put a large object on top of the sand I just get a dark or black space where the object is.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed.