-fpv in startup command not working

Home Forums AR Sandbox Forum -fpv in startup command not working

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #124969
    Anonymous
    Inactive

    Hey

    My issue with the ARSandbox startup command “cd ~/src/SARndbox-2.7 ./bin/SARndbox -uhm -fpv” is that with -fpv the program only shows black screen. When I remove -fpv from the line, program starts up but the projection is upside down.
    What could cause the lack of work with -fpv? Could the upside down image be because of some “+” and “-” mistakes in BoxLayout.txt?

    Edit: The water flow simulation creates an even layer of water on top of the topography, no matter the height. Any ideas on that?

    Thanks
    Hendrick

    #124977
    dantep
    Participant

    Hi Hendrick,

    This appears to be an issue for a lot of people. I am not sure what the cause is but there are at least 5 other users (me included) and posts about this issue. I have looked through the code and be unable to find any obvious causes. It may be a bug but I am completely stuck as well. Please share if you happen to figure it out.

    #125016
    Anonymous
    Inactive

    I just got mine up and running from scratch to have the same issue. Anyone have any luck? I have tried to just delete the Boxlayout.txt which I have read is the “issue” and i have tried changing some numbers around for science… with no luck… of course I have restored that file with a backup my made but there is no luck there.

    #125017
    Sean Robinson
    Participant

    Have you tried Step 6a of the software installation steps?

    https://web.cs.ucdavis.edu/~okreylos/ResDev/SARndbox/SoftwareInstallation.html#Step6a

    I had a similar, but less extreme, experience with the -fpv option. Calibrating my camera with Step 6a helped.

    #125018
    dantep
    Participant

    Hi Sean,

    I can not speak for the others but I am using a Kinect V2 which I don’t think benefits from that extra calibration. I have also been able to confirm that the depth is being detected correctly as the inverted image correctly shows my custom height map coloring, it is just colored on the wrong plane so appears beneath the depth image as opposed to on top of it. Let me know if you have any other suggestions, I appreciate the help.

    #125019
    Anonymous
    Inactive

    I am also using a Kinect v2. I have heavily changed the Boxlayout.txt to which the results where also the same. I did find a post that said that the first line of BoxLayout needed to changed for the Kinectv2 which brought the -uhm sorta correct? I will try to take pictures but it reads as though either the elevation is maxed or the sea level is high. The -fpv part will no work no matter what I try or how many times I adjust the Boxlayout.txt then run the ProjectorCalibration I am going to try and source a used Kinect V1 to see if it is just a kinect issue.

    #125036
    Anonymous
    Inactive

    I can confirm that is a Kinect V2 issue. Got a Kinect v1 off of ebay and now i am up and running with no issues

    #125076
    Anonymous
    Inactive

    So i tried the program after a while. On the first start ./bin/SARndbox -uhm -fpv didn’t launch an image (only a black screen). So i tried and just ran ./bin/SARndbox (without -uhm -fpv) (got topo image without colors). Closed it and ran ./bin/SARndbox -uhm (without -fpv) (got colors for the topo map). Closed it and tried to run ./bin/SARndbox -uhm -fpv and for some reason it worked.

    #125147
    Faiz
    Participant

    Anyone can solve this problem? I also faced with the same issues. I got a blank screen when running the command “cd ~/src/SARndbox-2.7 ./bin/SARndbox -uhm -fpv”. I’m using Kinect V2.

    Thanks
    Faiz

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Comments are closed.