Freeze Problem

Home Forums AR Sandbox Forum Freeze Problem

This topic contains 4 replies, has 4 voices, and was last updated by  GG_MEDL 2 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #100963

    basgan
    Participant

    After a few hours of working, Sandbox suddenly freezes. Our configuration is:

    Ubuntu 12.04
    Sarndbox 1.5.001
    Kinect 2.8.001
    Vrui 3.1
    GeForece GTX 760

    We have set the software to run on startup and change some settings in Vrui.cfg file to run on fullscreen, updateContinously and make the mouse cursor invisible.

    Any idea what could be the problem is?

    Thanks,

    #100982

    Oliver Kreylos
    Keymaster

    Does the AR Sandbox freeze completely, or does it just no longer receive data from the Kinect?

    To test, once it freezes, move the mouse (doesn’t matter that the cursor is invisible), and see if you get updates again. If you don’t, or you can’t tell, press the right mouse button to bring up the program’s main menu. Does it show up, and can you interact with the menu?

    If yes, then the Kinect is frozen. This could be a nasty problem, as there is no easy and reliable way to wake it up again. If you close the SARndbox application (by pressing Esc) and rerun it, does it work again? If not, does it work if you stop the app, unplug the Kinect, plug it back in, and rerun the app? Does it work if you run KinectUtil reset all instead of unplugging/plugging the Kinect?

    If you set updateContinuously back to false, does the sandbox freeze earlier? In general, using that setting is only a short-term workaround, as it will waste a lot of power and can potentially overheat the computer.

    #101241

    GG_MEDL
    Participant

    My ARS is freezing as well. Happens within seconds of running the program.

    – I can move the mouse.
    – I press the right mouse button and the menu does show up.
    – I can launch the scale bar
    – I can sometimes add water locally, but this is choppy and the contour lines do not change.

    – I reset the Kinect using the KinectUtil reset all, but this did not help.
    – I tried using the -wts 320 240, but this is not working either.
    – I adjusted the Performance Level on the Nvidia card to #3 135 MHz-1468 MHz …

    Other info:
    – drivers are up to date (Nvidia 346)
    – GPU 0 – (GeForce GTX 970)
    – LinuxMint 17.1 MATE (Downloading 17.2 now)
    – Thermal sensor information = 48 C (while currently frozen)

    #101857

    jKrienert
    Participant

    Having a similar problem to the above mentioned, post of the most recent SARndbox update.
    The trouble arises when making use of the (awesome) PIPE enabled live updates to attenuation and velocity of the active water simulation.
    Mouse and menu remain available, and when moving the mouse updates occur to the sandbox simulation in a rotoscoped manner (frame-by-frame).
    Anyone find a solution or clues to this yet?

    #102368

    GG_MEDL
    Participant

    The issue I was having was hardware related due to a short in the kinect after removing the base.

    (late update, I know…)

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Comments are closed.