Gigabyte BRIX

Home Forums AR Sandbox Forum Gigabyte BRIX

This topic contains 11 replies, has 3 voices, and was last updated by  marquant 3 years, 6 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #100925

    GregWirth
    Participant

    Tested Sandbox software on:
    Gigabyte BRIX
    Model: GB-BXi7G3-760
    16GB mem
    120GB SSD
    Nvidia chipset (760)

    60FPS with water model running. Works perfect. Ubuntu 14.04

    #101042

    marquant
    Participant

    Do you know of an alternative mini PC that is can be purchased for less?
    Thanks for your help.

    #101069

    marquant
    Participant

    Hello Greg,

    I have a similar setup to yours. When I tried installing Vrui, I did not get a spinning globe even though the installation was successful. Did you have any problems with this? I’m also running Ubuntu 14.04.
    Thank you for your help.

    #101070

    GregWirth
    Participant

    Hello.
    Are you sure you’re running the Nvidia drivers?

    #101071

    marquant
    Participant

    When I go into the Software & Updates< Additional Drivers it says that I am using NVIDIA binary driver – version 331.113 from nvidia -331 (proprietary tested).

    Does this seem ok? I’m pretty new to Ubuntu, so thank you so much for your help.

    #101072

    GregWirth
    Participant

    OK, so that is not the issue.
    I’ve never had that error and have installed and run quite a few of these now.
    Have you tried launching the SARandbox ?
    Does it also launch but not display?

    #101075

    Oliver Kreylos
    Keymaster

    When you run the following from a terminal window:

    ~/Vrui-3.1/bin/ShowEarthModel

    what response do you get in the terminal window?

    #101082

    marquant
    Participant

    Greg, thanks for your help. I believe that the Internet at the University has some sort of block. I brought the BRIX to my house and everything is running fine here.

    #101156

    marquant
    Participant

    Hello Greg,

    When I tried doing the intrinsic calibration to my Kinect (~/Vrui-3.1/bin/KinectUtil getCalib 0) I got the following message:

    lab@lab:~/src/SARndbox-1.5-001$ ~/Vrui-3.1/bin/KinectUtil getCalib 0
    terminate called after throwing an instance of ‘std::runtime_error’
    what(): Kinect::Camera::Camera: Less than 0 Kinect camera devices detected
    Aborted (core dumped)

    It seems to me like the Gigabyte BRIX is not recognizing my Kinect (I got the model 1473 Kinect)

    was there something that I have to download before running that line on the terminal (like maybe some sort of software from Microsoft? I plugged the Kinect to the BRIX straight out of the box).

    Thanks

    #101159

    GregWirth
    Participant

    Hello.
    Try running it like this:
    Note the: ~/Vrui-3.1/bin/KinectUtil getCalib

    sandbox@sandbox:/$ ~/Vrui-3.1/bin/KinectUtil getCalib
    Downloading factory calibration data for Kinect A70774700891341A…
    Depth conversion formula: dist[mm] = 345489 / (1089.41 – depth)

    Depth unprojection matrix:
    0.00173667 0.00000000 0.00000000 -0.55573332
    0.00000000 0.00173667 0.00000000 -0.41679999
    0.00000000 0.00000000 0.00000000 -1.00000000
    0.00000000 0.00000000 -0.00000289 0.00315323
    Depth-to-color pixel shift formula: Shift = 11.4115 – 13243.8/dist[mm]
    Or: Shift = -30.3492 + 0.0383333*depth
    Calculating best-fit color projection matrix for depth value range 399 – 975…
    Smallest eigenvalue of color system = 0.00111642
    Color matrix approximation RMS = 0.00946118
    Optimal homography from world space to color image space:
    0.00139920 0.00000842 0.00006000 0.01214831
    -0.00000539 0.00186429 -0.00000009 0.05945107
    0.00000000 0.00000000 0.00102564 0.00000000
    0.00000637 0.00000516 -0.00000017 1.00000000
    Intrinsic camera parameter file /home/sandbox/Vrui-3.1/etc/Kinect-2.8/IntrinsicParameters-A70774700891341A.dat already exists
    sandbox@sandbox:/$

    #101162

    marquant
    Participant

    This is what it is saying:
    lab@lab:~$ ~/Vrui-3.1/bin/KinectUtil getCalib
    terminate called after throwing an instance of ‘std::runtime_error’
    what(): Kinect::Camera::Camera: Less than 0 Kinect camera devices detected
    Aborted (core dumped)

    Any further suggestions?

    By the way, I greatly appreciate you for taking the time to help me with this.

    #101163

    marquant
    Participant

    By the way,

    Since I have the Kinect 1473 how do I download this the rule file that contains this:

    # Rules to relax permissions on USB files for Microsoft Xbox Kinect
    # This file was installed by the Kinect 3D Video Capture Project.
    # Copyright (c) 2013-2014 Oliver Kreylos

    # Rules for Kinect-for-Xbox model 1414:
    SUBSYSTEMS==”usb”, ATTRS{idVendor}==”045e”, ATTRS{idProduct}==”02ad”, TAG+=”uaccess”
    SUBSYSTEMS==”usb”, ATTRS{idVendor}==”045e”, ATTRS{idProduct}==”02ae”, TAG+=”uaccess”
    SUBSYSTEMS==”usb”, ATTRS{idVendor}==”045e”, ATTRS{idProduct}==”02b0″, TAG+=”uaccess”

    # Rules for Kinect-for-Xbox model 1473 and Kinect-for-Windows model 1517:
    SUBSYSTEMS==”usb”, ATTRS{idVendor}==”045e”, ATTRS{idProduct}==”02be”, TAG+=”uaccess”
    SUBSYSTEMS==”usb”, ATTRS{idVendor}==”045e”, ATTRS{idProduct}==”02bf”, TAG+=”uaccess”
    SUBSYSTEMS==”usb”, ATTRS{idVendor}==”045e”, ATTRS{idProduct}==”02c2″, TAG+=”uaccess”

    Thank you

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Comments are closed.