GL error!

Home Forums AR Sandbox Forum GL error!

Tagged: ,

This topic contains 8 replies, has 4 voices, and was last updated by  snerual 1 week, 6 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #117815

    snerual
    Participant

    Hi,

    When I try to run the AR sandbox I get this error (second line):

    vrhousedev@vrhousedev-GL503VS ~/src/SARndbox-2.5 $ ./bin/SARndbox -uhm -fpv
    GLWindow::setVsyncInterval: Unable to set synch interval to 1 due to GL error 5

    The AR sandbox does start, however, at a really low framerate (about 4fps). I have a dedicated PC with Nvidia geforce gtx

    I also ran the following:

    lspci | grep VGA
    vrhousedev@vrhousedev-GL503VS ~/src/SARndbox-2.5 $ lspci | grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation Device 1be1 (rev a1)

    vrhousedev@vrhousedev-GL503VS ~/src/SARndbox-2.5 $ glxinfo | grep vendor
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
    OpenGL vendor string: VMware, Inc.

    Does anybody have a solution to make the AR sandbox run at higher frame rate?

    • This topic was modified 1 month ago by  snerual.
    #117903

    Oliver Kreylos
    Keymaster

    OpenGL vendor string: VMware, Inc.

    It looks like you are running the AR Sandbox from inside a virtual machine. That won’t work (or only yield extremely low frame rates), as the AR Sandbox does not get access to the physical graphics card.

    #117942

    snerual
    Participant

    HI Oliver,

    Thank you for your reply. I am not running it from inside a virtual machine. I installed Linux on the laptop and can start this from the boot menu.

    Kind regards,
    Laurens

    #117943

    snerual
    Participant

    When I use:

    sudo dmidecode | grep Product

    It results in:

    Product Name: GL503VS

    #117951

    Oliver Kreylos
    Keymaster

    In that case, you didn’t install the Nvidia driver, or something went wrong during its installation. Without the driver, the grapbics card won’t be used.

    #117952

    snerual
    Participant

    Thank you for your reply. Yes, I have a feeling that that is the problem too. The computer does not seem to succesfully install and use the recommended nvidia driver. When I open Nvidia-settings, there is not info there after I installed it, so it seems that it fails to install this driver.

    I already tried installing other Nvidia drivers that should be suitable for the PC, but this does not work as well. I will give it a try now on another PC to see if that works.

    #117953

    raviraushan01
    Participant

    Try different method. WiFi Names I already tried installing other Nvidia drivers that should be suitable for the PC, but this does not work as well. I will give it a try now on another PC to see if that works.

    #117957

    jasdeep09
    Participant

    try to run it from inside a virtual machine. try to watch movies install Linux on the laptop, try different methods

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Comments are closed.