gl.h not found

Home Forums AR Sandbox Forum gl.h not found

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #123989
    codingman
    Participant

    Hello Everybody.
    I want to set up my own SandBox. I’ve installed Linux Mint as instructed. But when i want to install the SARndbox software, it crashes and an error pop up saying: GL/gl.h not found!
    Can you helpme with this please.
    I’m using an ultrabook thinkpad S440 with an AMD RADEON graghic Card
    Regards

    #123990
    jill
    Participant

    Hi Codingman,

    The software is not finding the OpenGL header file (GL/gl.h) it needs to run. OpenGL is included in drivers, so make sure the graphics card driver for your RADEON card is properly installed and that the software is using the right path to find it.

    I recently installed Linux Mint and ran the AR Sandbox software and did not have this issue, but I was using a machine with an NVIDIA graphics card and thus downloaded and installed the NVIDIA driver. NVIDIA video cards and drivers have been recommended for AR Sandbox because in the past AMD driver support for Linux was poor.

    #124003
    jill
    Participant

    To add to the above, when running make to build Vrui without the script, I ran into the error:

    fatal error: GL/gl.h: No such file or directory

    Running

    $ dpkg -S /usr/include/GL/gl.h

    I received the reply

    dpkg-query: no path found matching pattern /usr/include/GL/gl.h

    I needed to install the -dev version of the package. I ran

    $ sudo apt-get install mesa-common-dev

    to fix it.

    #124014
    codingman
    Participant

    Hello Jill.
    First, thank you for your reply.
    The main problem in my case is the ATI/RADEON graphic card driver.
    Until now i didn’t succeed to install the ATI/RADEON driver properly. I’m using another laptop with NVIDIA Card , and it’s worked fine to me.
    I’m planning to get time and space to resolve this ATI/RADEON graphic card issue. I’ll post my results later.
    Best regard

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Comments are closed.