GTX 1060 Driver Issues

Home Forums AR Sandbox Forum GTX 1060 Driver Issues

This topic contains 3 replies, has 3 voices, and was last updated by  dlarue 1 week, 2 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #118509

    nick
    Participant

    Hello AR-Sandbox Peeps,

    I’ve purchase a MSI Trident 3 gaming PC with an GTX 1060 GPU. I’ve run into some issues with the nvidia drivers. After using the control center to select, install and reboot the system with the ‘nvidia-driver-390’ driver I checked for proper installation using:

    $ lspci | grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 3GB] (rev a1)

    $ glxinfo | grep vendor
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
    OpenGL vendor string: nouveau

    I downloaded other Nvidia drivers (396, 410, & 415) and repeated the select-install-reboot procedure and received the same output I did before (shown above).

    The systems is running Linux Mint 19.1 64 bit.

    I’ve searched the forums for similar problems and apologize if I’ve missed answers or documentation which would help me solve this problem.

    Should I continue installation and? Any ideas to get the system to show the proper vendor data?

    Thank you,

    Nick

    • This topic was modified 2 months, 3 weeks ago by  nick.
    #118510

    Oliver Kreylos
    Keymaster

    I’ve recently run across a similar problem. First off, don’t ignore and continue; things won’t work. The AR Sandbox software won’t be able to access the graphics card’s full feature set.

    Check your BIOS settings next time you reboot. If your boot options are set to “secure boot,” or sometimes it’s called something like “boot for Windows,” then try switching to legacy boot mode, which might unfortunately require a re-install of Linux — try if you can boot into your existing Linux installation first.

    While “secure boot” should work with Linux Mint, there might be the odd motherboard where it causes issues. Not being able to access the graphics card can be one of those issues.

    If you’re already in “legacy mode,” switch to the other mode.

    #118512

    nick
    Participant

    Disabling secure boot solved the problem. Thank you, Oliver!

    Here are the steps which allowed the Nvidia drive to be recognized:

    1. During boot press the ‘Delete’ key BEFORE the MSi logo first appears.
    2. Make sure you are on the ‘EZ Mode’ screen. It should say ‘EZ Mode’ in a tab across the top of the screen on the right. If it doesn’t click the word ‘Advanced’ or press ‘F7’ to toggle between EZ and Advanced Mode.
    3. Click the ‘Settings’ tab on the left.
    4. Select Advanced > Windows OS Configuration > Secure Boot > Secure Boot Support.
    5. This will open a dialog where you can Enable/Disable Secure boot.
    6. Press X in top right corner, confirm changes and reboot.

    #118656

    dlarue
    Participant

    Thank you @nick for posting those steps. I built a bootable ISO with CUDA support for a CNN project(DIYRoboCar) and a roboticist could not get the bootable system to detect the Nvidia card. Should be a walk in the park now. Thank you.

    I’m hoping to build an AR Sandbox some day but my Asus Xtion Pro is not supported( native Kinect instead of OpenNI APIs ) and not sure I’ll get around to porting it. The local science center( Rubin H Fleet Science Center ) has 2 AR Sandbox exhibits and the kids love it.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.