Having issues with video drivers for GTX 970

Home Forums AR Sandbox Forum Having issues with video drivers for GTX 970

This topic contains 2 replies, has 2 voices, and was last updated by  mmcclain 3 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #101110

    mmcclain
    Participant

    I’ve tried both Ubuntu 14.04.1 and the recommended Mint 17.1 installs and neither will work. When I try to follow the video for instructions on installing the linux OS and the video driver through the “driver manager” it does not show any results. I have the recommended GeForce gtx 970 card, in a Dell optiplex 970 w/ 4 gig’s of ram and a corsair 600w P/S. The OS’s will install but they seem to not detect the card. I tried downloading the linux 64 bit driver for this card and install it manually, but that will not work either. What am I doing wrong ?

    TIA

    – Mark

    #101112

    fredjiencke
    Participant

    Hello-

    I am having a very similar problem. I am using an

    Intel Core i7-4790 CPU @ 3.6GHz.

    NVIDIA GeForce GTX 970 video display adapter (recommended card)

    Any help is much welcomed and appreciated.

    Thanks,

    Fred

    #101115

    mmcclain
    Participant

    Fred –

    I figured it out after some google searching. You basically have to disable the xserver ( gui interface ) of mint and login as root. I downloaded the drivers from nvidia copied them to my home directory, disabled the xserver, logged in as root, navigated over to my home directory and kicked of the installer from there. One of the issues I had was after I ran the command from a terminal window my screen was completely black. The problem ended up being the fact that I was using a 4 x 3 monitor and the text was being displayed off screen. I swapped out a wide screen monitor to fix that issue. Here’s some links that should help you:

    http://forums.linuxmint.com/viewtopic.php?f=59&t=196984

    http://us.download.nvidia.com/XFree86/Linux-x86_64/352.21/README/installdriver.html

    When you login as root use the same password you used when you created the user during the installation of Mint.

    Hope this helps…..

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed.