How can Vrui inhibitScreenSaver be disabled?

Home Forums AR Sandbox Forum How can Vrui inhibitScreenSaver be disabled?

This topic contains 3 replies, has 3 voices, and was last updated by  Oliver Kreylos 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #103423

    MBadham
    Participant

    Hello everyone

    We are putting together an AR Sandbox as a museum exhibit at Queen’s University in Kingston, Ontario, Canada. We have the system running, and we have implemented usb buttons to start the program, drain/evaporate water, and exit the program. Ideally we would like the projector to go to sleep after a period of time in order to extend the bulb life though. It seems to us that the easiest way to do that would be to let the Linux screensaver blank the screen after maybe 15 minutes, and instruct the user to press the “start” button in order to wake up the system.

    The Vrui “inhibitScreenSaver” function seems to be on by default though, which means that the linux system is never allowed to blank the screen whenever the sandbox software is running. I have tried to change the inhibitscreensaver values to false wherever they are mentioned in Vrui.cfg with no effect (these were in sections for OculusRift and VIVE settings though). We also tried adding the setting “inhibitScreenSaver false” in the Desktop section, and simply as a standalone line on its own in vrui.cfg but it never seems to have any effect. We are not entirely linux savvy, so it is probably just a problem with the way we are entering it in the Vrui.cfg file. Does the “inhibitScreenSaver false” line need to go in its own defined section in the .cfg, and can anyone supply an exact “cut and paste” for us to put in the file in order to allow screen blanking while the sandbox software is running?

    Furthermore, does anyone know if defeating inhibitScreenSaver will have the desired effect of letting linux blank the screen, but still allow a press of a usb button to wake it up again with the sandbox software running? Do other display sandboxes just simply stay on all the time, or is there another solution? We have searched the forums and the Internet as a whole and can’t seem to find a solution that allows the press of a button to start the program again.

    All help is appreciated,
    Mark

    #103561

    Oliver Kreylos
    Keymaster

    The underlying Vrui toolkit supports per-application configuration files, for example, to enable screen saver inhibition for the AR Sandbox, but leave it off for other applications.

    You will find a SARndbox.cfg configuration file in your user configuration directory, /home/username/.config/Vrui-/Applications. You can set inhibitScreenSaver to false in that file.

    #115434

    clifcox
    Participant

    Hello again,

    I also noticed the inhibitScreenSaver setting in the OculusRift and VIVE sections of the main config file, and left them alone thinking they did not apply. I did try to set it to false in several local files under /home/sandbox/.config, eg:

    In .config/Vrui-4.5/Vrui.cfg:

    section Vrui
        section Desktop
            section MouseAdapter
    			inhibitScreenSaver false
            endsection
    endsection

    In .config/Vrui-4.5/Applications/Vrui.cfg:

    section Vrui
    	inhibitScreenSaver false
        section Desktop
    			inhibitScreenSaver false
        endsection
    endsection

    and in .config/Vrui-4.5/Applications/SARndbox.cfg:

    section Vrui
        section Desktop
            section MouseAdapter
                mouseIdleTimeout 5.0
    			inhibitScreenSaver false
            endsection
            
            section Window
    			outputName HDMI-0
    			windowFullscreen true
    			inhibitScreenSaver false
            endsection
            [...]

    I tested these with the screen saver timeout set to one minute and when the sandbox was not running it went to the screen saver but not when it was running. Sooooo, where exactly should you put the inhibitScreenSaver false config option? 🙂

    Thanks much,
    Clif

    #115479

    Oliver Kreylos
    Keymaster

    The inhibitScreenSaver setting is part of a Vrui root section (see reference). I.e., you’ll find it as

    section Vrui
        ...
        section Desktop
            ...
            inhibitScreenSaver true
            ...
        endsection
        ...
    endsection

    You can see exactly which configuration files are read at program start-up by adding -vruiVerbose to the command line. Check all of those; someone must have put “inhibitScreenSaver true” in at least one of those, as it’s false by default.

    Then either set the setting back to false, or remove the entire line.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.