How to upgrade Vrui and Kinect?

Home Forums AR Sandbox Forum How to upgrade Vrui and Kinect?

This topic contains 2 replies, has 1 voice, and was last updated by  liudr 8 months, 4 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #110898

    liudr
    Participant

    The complete installation instruction is installing Vrui 4.2 and Kinect 3.2. I have everything running. I want to upgrade to Vrui 4.3 and Kinect 3.3 for support on xbox one kinect. I am finding it very difficult as there are not enough instructions to do so.

    Here I found Kinect 3.3 that requires Vrui 4.3:

    Kinect

    I downloaded Vrui 4.3 and compiled it. I then installed it. I downloaded Kinect 3.3 and compiled it. I then installed it as well. I did my best to get the raw video showing with both depth and visible light camera but I couldn’t start the sandbox because some files are being sought after in Dr. Kreylos’ own folder:

    Terminated Sandbox due to exception: IO::StandardFile: Unable to open file /home/okreylos/Projects/Kinect/ColorMatrix.dat for reading due to error 2 (No such file or directory)

    Trying to run this KinectViewer program results in error caused by the same thing.
    ar@arsandbox ~/src/Kinect-3.3 $ KinectViewer -c2 0
    Terminated KinectViewer due to exception: IO::StandardFile: Unable to open file /home/okreylos/Projects/Kinect/ColorMatrix.dat for reading due to error 2 (No such file or directory)

    Where do I go from here?

    #110902

    liudr
    Participant

    I cleaned and made sarndbox 2.3 again but still it wants files on Dr. Kreylos’ computer LOL There might be a newer version that’s not posted yet. I did everything I could. The Vrui 4.3 and Kinect 3.3 are working. I could run RawKinectViewer and extract plane and points. I couldn’t calibrate the projector as it is part of the Sarndbox program that I suspect needs an update as well.

    #110960

    liudr
    Participant

    I found in the SARndbox 2.3 source code that some of the folders are pointing at the 4.2 version of VRui. I’ll give it a try to see if I can update them and compile it to run with VRui 4.3. It’s not easy to modify the source code. I wish there’s an update.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed.