Keyboard causing system freezes

Home Forums AR Sandbox Forum Keyboard causing system freezes

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #124057
    PasiT
    Participant

    Hello everyone! I’m building my second AR Sandbox and came across some weirdness in key assignments and keyboard commands in Vrui applications, including the globe demo and RawKinectViewer. Both work well when using mouse, but using keyboard results in partial freezing of the system. Mouse pointer can be moved, but other inputs are inactive. In the globe demo the duration of the freeze is in the order of seconds, in RawKinectViewer from ten seconds up to infinity. I have run the applications in vruiVerbose mode, but nothing shows up there, it just runs in the main loop.

    I have encountered this now on two laptops, a Huawei Matebook with AMD Radeon Vega GPU I was working on first and an ASUS M570 with GeForce GTX1050 GPU that I got as a replacement. The OS used is Linux Mint 19.3 Tricia (I could not get 19.1 Tessa to boot on the ASUS, so I stuck with Tricia), other software is according to the AR Sandbox installation instructions, apart from GPU drivers on the Radeon machine. I seem to have some issues with Nvidia drivers on the ASUS too, the recommended Nvidia-435 drivers are installed in system settings but glxinfo does not return any Nvidias.

    Could this be a GPU driver related thing, or does Tricia differ in some critical way from Tessa or Tara? I have tried various dead-end fixes, with no luck: iommu=pt, manual driver installations, continuous polling in vrui etc…

    I built my first AR Sandbox three years ago and managed to do the software installations and calibration in one day and it has been perfect since. Now I have been working with this new installation for a week and haven’t got very far yet. I would appreciate comments on where to go looking next.

    #124065
    pfiction
    Participant

    I also had this problem with Mint 19.3 MATE desktop. I had the same results on another machine with different hardware and the same OS. Switching to 19.3 Cinnamon worked and i also installed 19.1 MATE on my sandbox rig which works fine.

    #124066
    PasiT
    Participant

    Thank you! I changed to 19.3 Cinnamon and it works.

    #124088
    Oliver Kreylos
    Keymaster

    Edit Vrui.cfg, by default in /usr/local/etc/Vrui-<version>:

    $ sudo xed /usr/local/etc/Vrui-4.6/Vrui.cfg

    Find the section called “MouseAdapter” and insert the following line into it:

    grabPointer false

    Then save Vrui.cfg. That should fix it.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Comments are closed.