Killing the X-Server – Not working

Home Forums AR Sandbox Forum Killing the X-Server – Not working

This topic contains 8 replies, has 4 voices, and was last updated by  scruffyjoe 4 years ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #100932

    Rickshaw
    Participant

    This is more of a Linux issue than a sandbox issue, but it has stopped me cold for almost 2 weeks, and I need help. I’m a Linux newbie, but learning lots trying to troubleshoot this issue.

    I bought a new GeForce GTX 970, and a previously-owned Core i3 tower. But when I go to install the Nvidia 346.47 driver, I need to stop the x-server. ($ sudo /etc/init.d/lightdm stop)

    It’s “supposed to” go to a text window (like ctrl-alt-F1) where I can continue to install the driver, but instead, it goes to a black screen and locks me out. Manual power-off button is the only cure.

    Interestingly, Ctrl-Alt-F1 doesn’t bring up a text terminal, and neither do F2-F6. (But I can get back with F7)

    Also interestingly, it happens exactly the same way in both Ubuntu and Linux Mint, which makes me think it’s a hardware compatibility issue between the MB and the GTX 970.

    I’m about to install Ubuntu 14.04.1 (http://old-releases.ubuntu.com/releases/14.04.1/) to see if that resolves the issue.

    I am a Linux newbie, except for the past several weeks of trying to get this to work. I’m $500 into this project, and I haven’t even built the sandbox yet… Any help from this community is greatly appreciated!!

    #100933

    MikeD
    Participant

    We encountered this when we attempted to terminate x-server while using the nvidia card as the output.

    Our perhaps dirty workaround was to quit the x-server while using the built-in video output on our motherboard. This dropped us into command line instead of the black screen and allowed the installation to continue as normal!The table is running great now.

    By way of encouragement don’t let this particular process get you derailed! You can get the the entire table and application running without the need for graphics card to be running as that the only process really dependent on it is the simulated water!

    #100934

    Rickshaw
    Participant

    Of many different solutions I found online, I finally found a set which worked for me.

    (From http://askubuntu.com/questions/162535/why-does-switching-to-the-tty-give-me-a-blank-screen)

    —–
    This is usually caused because the graphical text-mode resolution set at boot up is not compatible with your video card. The solution is to switch to true text-mode by configuring Grub appropriately:

    Open the terminal with Ctrl+Alt+T
    Paste the below, and enter your password when asked:

    sudo sed -i -e ‘s/#GRUB_TERMINAL/GRUB_TERMINAL/g’ /etc/default/grub

    Then type sudo update-grub

    Reboot and the virtual terminals should now work.

    ——-
    They do, however, I also found that I could only install the drivers from a text window (ctrl-alt-F1). They would not install from a terminal in the GUI.

    In fact, I found that I needed to install most of the sandbox software from a text window, which was not necessary with my older video card.

    Calibrating my box and Kinect this week. Hopefully everything else goes well!!

    – Rick

    #100942

    Oliver Kreylos
    Keymaster

    Did you download the Nvidia driver blob directly from Nvidia’s site, or did you go through Ubuntu’s built-in “additional drivers” control panel? The former method is more complex because it has to be run from an X-less console; the latter one is more-or-less point-and-click.

    #100948

    Rickshaw
    Participant

    Did you download the Nvidia driver blob directly from Nvidia’s site, or did you go through Ubuntu’s built-in “additional drivers” control panel?

    Yes, I tried the Ubuntu “Additional Drivers” control panel, but there were no drivers listed. All I got was blank window with something like: “No proprietary drivers are in use.”

    Conversely, in Linux Mint, there was a Nvidia Alternate Driver listed, but it would never install fully, so I’m back to Ubuntu. In other words: It appears Mint recognizes my card in the computer but won’t finish the driver installation, and Ubuntu must be forced to recognize the card outside the x-server.

    Based on the 2 different computers that I was using to prototype my sandbox, and nearly 100 hours of troubleshooting, it’s my experience that the same version of Linux run on 2 different motherboards will yield different results and issues… and vice/versa: Different Linux operating systems (but based on the same Kernel) will perform differently on the same hardware.

    I’m planning a full-writeup for complete re-installation, in case the hard drive crashes, or the projector needs recalibration in later years. I can post all of that here when I’m done.

    #100949

    Oliver Kreylos
    Keymaster

    I just did a from-scratch Ubuntu 14.04 install for a video to accompany the complete instructions, and it went all the way through with one minor hitch (full-screen toggle).

    When I went to the “additional drivers” panel, it was initially empty, but then filled up with the list of Nvidia drivers after about a minute. From there I just clicked on the first choice, pressed apply, and was off to the races.

    #100950

    Oliver Kreylos
    Keymaster

    I just did another from-scratch install, this time Linux Mint 17.1 MATE, and it also went through without a hitch. I’m sorry that you had such issues on your side.

    #101105

    scruffyjoe
    Participant

    Hi Rickshaw

    I was having the same installation problem yesterday evening. No additional drivers show up for the graphics card. Tried a few methods online and still no avail. What steps did you follow, any help be much appreciated.

    #101107

    scruffyjoe
    Participant

    Solved it

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed.