Kinect not detected

Home Forums AR Sandbox Forum Kinect not detected

This topic contains 5 replies, has 5 voices, and was last updated by  mikesmith32 3 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #101098

    marcos
    Participant

    I followed all the steps listed here up to step 5 where I have to run ~/Vrui-3.1/bin/KinectUtil getCalib 0
    At that point I input the command and I receive this message:

    terminate called after throwing an instance of 'std::runtime_error'
      what():  Kinect::Camera::Camera: Less than 0 Kinect camera devices detected
    Aborted

    The kinect and power adaptor definitely work. They have already been tested on a Windows OS and they work just fine.
    Before I completed any of the steps in the instructions, the camera could be found in lsusb. Somewhere later, the camera disappeared and only Microsoft Corp. Xbox NUI Motor would appear.

    OS: Linux Mint 17.1 “Rebecca” – MATE (64-bit)
    USB 2.0
    Kinect model 1414

    • This topic was modified 3 years, 8 months ago by  marcos.
    #101147

    Oliver Kreylos
    Keymaster

    This should work, but the Kinect is sometimes temperamental. Run

    $~/Vrui-3.1/bin/KinectUtil reset 0
    

    first, or if that doesn’t help, unplug and replug the Kinect.

    #101264

    ninjaneerstudios
    Participant

    Hey Marcos,

    We were getting the same msg as well:

    terminate called after throwing an instance of ‘std::runtime_error’
    what(): Kinect::Camera::Camera: Less than 0 Kinect camera devices detected
    Aborted

    The light on the Kinect was blinking sporadically and would go off. The solution that worked for us was to go buy a PCI Express USB 3.0 Card that is also powered from your PSU. The problem is that your normal USB ports and the XBOX Kinect AC Adapter are not enough power. After this, VRui detects the kinect every time. We tried several more kinect’s just to make sure it wasn’t a fluke.

    I will list our setup below:

    CPU: i7 Hasswell
    GPU: 970 GTX CeForce Nvidia
    PSU: 750W
    HDD: 120gig SSD
    RAM: 8 gig
    MB: Asus Sabertooth z87 Motherboard
    OS: Linux Mint with Mate (with all updates) I believe the new one is 17.2 codename Rafaela
    USB 3.0 PCI Express Cars that can also be powered by the PSU

    Joe R

    #101797

    mikesmith32
    Participant

    Hello,

    I am using the adapter (http://www.amazon.com/gp/product/B004S7GA46/ref=pd_lpo_sbs_dp_ss_1?pf_rd_p=1944687742&pf_rd_s=lpo-top-stripe-1&pf_rd_t=201&pf_rd_i=B00JVI6BVY&pf_rd_m=ATVPDKIKX0DER&pf_rd_r=0WRV754BKA4K863SC3R7) and I have concluded that it is not providing enough power to my Kinect. The green light on the Kinect is blinking sporadically and I get random outputs of the motor, audio, and camera when using the “lsusb” command.

    I understand the solution of using a USB 3.0 PCI Express Card but for mobility I’m using the Cooler Master Elite 130 Mini ITX Tower Case. It supports only Mini ITX motherboards which have only one PCI-E X16 slot. My graphics card takes up the only slot and I cannot afford to purchase a new case and motherboard, so I need a different solution.

    Is there any way I can get more power to the Kinect through the Power Supply AC Cable Adapter? Could I possibly rewire or modify the circitry to provide more power? I am open to any ideas or solutions you guys can think of.

    Power Supply – CS450M
    Graphics Card – GeForce GTX 750Ti
    CPU – Intel Pentium G3258 LGA1150 socket
    Motherboard – ASrock H81M-ITX
    Kinect Model – 1414

    Thank you for the help,
    Mike

    #101799

    Ross
    Participant

    Worth checking your BIOS to see if you can find an option named “USB 2.0 HS Reference Voltage”. If that option is available, change the associated value from “Low” or “Medium” to “High” or “Maximum”.

    #101805

    mikesmith32
    Participant

    Thank you for the reply,

    Unfortunately my motherboard does not support that feature.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Comments are closed.