Kinect v2 maximum height

Home Forums AR Sandbox Forum Kinect v2 maximum height

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #124906
    sbj
    Participant

    Hey all,

    I’m currently working in a local museum trying to setup up the arsandbox. Since they didn’t plan the physical construction for this software, I am now running into some problems while configuring the ssandbox software.

    Our sandbox is roughly 62″x47″ but the Kinect is mounted roughly 90″ above the sandbox itself. So it covers alot more then just the physical box. We now have Problems with the last Calibration step because the disk doesn’t get recognized when being held close to sand surface. I have to hold it above the corners of the box for the disk to turn steadily green. Because of that we are not able to configure the sandbox properly to get it running for visitors to use. I also tried playing around with the sea level via the BoxLayout File but that did not seem to do the trick.

    My only guess now is that the Kinect is mounted way to high to properly see the change in the sand but I’m not sure if I’m missing something.
    Is there any way to fix this without mounting the Kinect lower or is it the only possible way to get the sandbox properly running?

    Feel free to ask if anything is unclear about our setup. I’ll gladly provide more information about it.

    Thanks in advance!
    Sebastian

    #124911
    paguy
    Participant

    I would say too high, my sandbox is about 40% smaller than yours 1m x 0.75m and kinect to base plane is about 1.1m. Keeping those proportions I would expect your kinect height to be ~1.6m or 60″. The higher you go the larger the pixel size on the sand surface so is going to be less sensitive to surface features as well as loosing light intensity, making it more likely that ambient light drowns out the return the Kinect is looking for. Mine is kinect 1, which uses a different method of distance measurement but the effect of height is going to be similar.

    #124934
    sbj
    Participant

    Thanks for the answer. We set it around ~1.6m now and the calibration is way smoother than before.

    But we run into another problem now. After the calibration is finished where I made sure that the disc is properly followed by the red cross in the last step, the sandbox just stays black with some little textures on the right side. But there are nor proper contour lines or anything like that. This happens when I start via the -fpv command to force the usage of the calibration matrix from the last step. If I start it without the fpv flag I can rotate the image by 180° and get a inverted view of the sandbox with contour lines and everything. Besides being inverted it seems to work properly when moving sand and stuff.

    I have 2 things that I suspect being the issue here:

    1. The problem lies with the Kinect for XBOX One and it somehow fails the last calibration step and therefore the calibration matrix.
    2. We running on an AMD card currently since its just a preconstructed PC bought from somewhere. It should have enough power to handle everything but I feel like it may still be issued even tho its works without the -fpv command in some way.

    Does anyone has any input on how to proceed? I haven’t found any forum entries that represented my exact problem so far, maybe I’ve missed them.

    Would be glad if someone could help me out!
    Cheers
    Sebastian

    #124943
    dantep
    Participant

    Hello sbj,

    I was wondering if you where able to figure out the issue you are experiencing above? I am running into the exact same issue. I am using a Kinect V2 (Xbox One) and my calibration is successful but when I run the Sandbox with and without -fpv I get the same results as you do. I am not sure if this is some sort of bug in the code since I found one more post similar in the Common issues thread that was also never answered. To address your second concern, the PC I am using is strong enough to run everything with zero concerns so I am not sure it is a PC power issue. It seems to me that the coloring is not being displayed on the correct plane since as you mentioned, the coloring is all correct but the image has to be inverted so projecting it over the sandbox does not provide valuable functionality. Please let me know if you were able to fix this. Thank you.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Comments are closed.