Minor software update

Home Forums AR Sandbox Forum Minor software update

This topic contains 9 replies, has 7 voices, and was last updated by  RodgerHoll 2 years, 7 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #101486

    Oliver Kreylos
    Keymaster

    I just released a new minor version of the SARndbox package, 1.6. It also requires a new Kinect package, 2.8-002, which in turn requires a new Vrui package, 3.1-004.

    The main user-visible change in Vrui-3.1-004 is a built-in keyboard shortcut to toggle a window’s full-screen state (Win+f).

    SARndbox-1.6 primarily offers new tools and features to control the behavior of a running AR Sandbox from inside or the outside:

    • A new “Pause topography” tool to pause/unpause real-time updates to the scanned topography map.
    • A dialog window to control parameters of the water simulation (simulation time scale, maximum number of steps, and velocity attenuation value), and to see the current display frame rate. The attenuation slider can be used to change the behavior of the simulated fluid. At small values (the previously hard-coded value, and new default, is 1/128) the fluid behaves like water; at large values (around 0.9) it behaves more like lava.

      The water control dialog can be opened via the main menu.

    • A POSIX named pipe to set the values of several internal parameters from outside sources (scripts etc.)

    The named pipe works as follows. First, you need to create a pipe somewhere in the file system. A good place would be the SARndbox resource directory, ~/src/SARndbox-1.6/share/SARndbox-1.6 in the default installation. The pipe can have any name. To create one:

    $ cd ~/src/SARndbox-1.6/share/SARndbox-1.6
    $ mkfifo Control.fifo

    Then, you tell SARndbox the control pipe’s name via the -cp command line parameter:

    $ cd ~/src/SARndbox-1.6
    $ ./bin/SARndbox <usual parameters> -cp ~/src/SARndbox-1.6/share/SARndbox-1.6/Control.fifo

    Once the sandbox is running, you can control it by writing commands to the named pipe. For example,

    $ echo "waterAttenuation 0.99" > ~/src/SARndbox-1.6/share/SARndbox-1.6/Control.fifo

    will immediately change the water velocity attenuation value to 0.99, which might work well for “simulating” lava.

    The following commands are currently supported:

    • waterSpeed <speed>

      Sets the water simulation time scale factor to <speed>, a value larger than or equal to zero.

    • waterMaxSteps <maxNumSteps>

      Sets the maximum number of water simulation steps per frame to <maxNumSteps>, an integer larger than or equal to zero.

    • waterAttenuation <attenuation>

      Sets the water velocity attenuation to <attenuation>, a value larger than zero and smaller than or equal to one.

    • colorMap <color map name>

      Loads a new color map from a file named <color map name>

    #101495

    billberet
    Participant

    that’s great, it’s nice to see everyone’s requests being incorporated into new versions.
    and I just finished getting everything running smoothly, but then again, that’s what backups are for!!

    #101502

    INTPTT
    Participant

    Awesome Oliver, thank you! I’m with Bill – just got it running pretty smoothly. But this will give Jensen more to do. =) Now I need more buttons to map things too…

    #101529

    billberet
    Participant

    INTPTT, have you updated to the new version yet?
    I’m so happy with the way things are running now, I want to wait till someone else takes the plunge !!!!!

    #101535

    @kmattr2050
    Participant

    Oliver,

    thank you for responding to my other posts. With this new update, will it work for a system with the following specs?

    -Computer-
    Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
    Memory : 2047MB (653MB used)
    Operating System: Ubuntu 15.10
    User Name : sand (Sand)
    Date/Time : Sun 08 Nov 2015 05:20:01 PM EST
    -Display-
    Resolution : 1024×768 pixels
    OpenGL Renderer : Unknown
    X11 Vendor : The X.Org Foundation
    -Multimedia-
    Audio Adapter : HDA-Intel – HDA NVidia

    Operating System
    —————-
    -Version-
    Kernel : Linux 4.2.0-16-generic (x86_64)
    Compiled : #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015
    C Library : Unknown
    Default C Compiler : GNU C Compiler version 5.2.1 20151010 (Ubuntu 5.2.1-22ubuntu2)
    Distribution : Ubuntu 15.10

    My GPU is an AMD Radeon 1540/1520. When I run the main Sandbox application, the 3D rendering is painstakingly slow to react to the mouse and keyboard. I have attempted to complete the Kinect and projector calibration steps but was not very good at it as I received:

    Calibration error: Some tie points have negative projection weights. Please start from scratchCalibration error: Some tie points have negative projection weights. Please start from scratch.

    I will be reattempting tomorrow but did not know if it would be a futile attempt if my machine is not up to par?

    #101540

    Oliver Kreylos
    Keymaster

    You won’t have much success with that machine. Your CPU (Athlon 64 X2) is about a factor of 7 slower than our minimal recommended CPU (Intel Core i5), and while I didn’t find a Radeon card with a 1540 or 1520 model number, I’m assuming it’s the same vintage as the CPU (2009), and probably won’t be powerful enough.

    You might be able to run the AR Sandbox without water simulation by appending -ws 0.0 0 to the command line, but even then it might be slow.

    To avoid the error message during calibration, ensure that the Kinect tracks your calibration target properly before confirming a tie point, and that you don’t move the target for 2 seconds after confirming. The target disk is supposed to show up green in the real-time calibration display.

    #101616

    maphew
    Participant

    @kmattr that’s the same CPU I have, and twice the RAM. Mine works (SARndbox 1.5), albeit with a heart beat pause before update; CPU% is about 85-90%. With water animation turned in it’s 2 or 3 beats and CPU is pegged to 100%.

    very short video of it in action: https://goo.gl/photos/ik9rAN6Y1KsayR3Y7

    System stats:

    -Computer-
    Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
    Memory : 1015MB (590MB used)
    Operating System : Ubuntu 15.04
    User Name : hello (hello)
    Date/Time : Thu 12 Nov 2015 08:21:30 PM PST
    -Display-
    Resolution : 2720×900 pixels
    OpenGL Renderer : Unknown
    X11 Vendor : The X.Org Foundation

    -Video Card-
    G84GL [Quadro FX 1700]

    #102006

    ritu
    Participant

    colorMap <color map name> how to use this can anyone here guide me??

    #102023

    Oliver Kreylos
    Keymaster

    If you created a control pipe Foo.fifo via

    $ mkfifo Foo.fifo

    and then ran SARndbox with the additional -cp Foo.fifo command line argument,

    and created a color map file Bar.cpt, then you can

    $ echo "colorMap Bar.cpt" > Foo.fifo

    to immediately load the color map in Bar.cpt while the AR Sandbox is running.

    #102177

    RodgerHoll
    Participant

    Trying to get the color map to load. I have the pipe working. tested it with waterAttentuation.

    when issuing the command “colorMap orig.cpt” the terminal window the sandbox is running in give and error.
    “Cannot read height color map orig.cpt due to exception IO::StandardFile: unable to open file orig.cpt for reading due to error 2”

    I take this means It cannot file the file. it is a copy of the default color map, I have tried placing it in the etc folder , in the share folder ?? where is it supposed to be located for the pipe command to work?

    I can load it via the command line options when it is in the etc folder.

    Rodger

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Comments are closed.