No such file issue during install

Home Forums AR Sandbox Forum No such file issue during install

This topic contains 2 replies, has 2 voices, and was last updated by  devan 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #113960

    devan
    Participant

    hi everyone! building a box for an 8th grade science class in a public school on the lower east side of manhattan.

    it’s a new machine we built from components that meets all the reqs. seems to be working fine. Mint 18.3 install went fine. driver updates went fine. Vrui build was successful. Saw the globe.

    but when we try to run make in Kinect-3.2, we get a string of no such file or directory.

    i noticed that the Vrui folder created was Vrui-4.5-001 and the make was looking for -4.2. we tried renaming the folder, no luck. we tried altering the Vrui makefile (suggested in the Kinect-3.2 folder’s readme), no luck. i’ve read around the forum but i’m not seeing anything to help.

    any suggestions would be so appreciated. thank you everyone and especially oliver for all your work.

    #113967

    Oliver Kreylos
    Keymaster

    As the Kinect package’s README file says:

    Installation Guide
    ==================

    3. If the Vrui version installed in step 0 was not 4.2, or Vrui’s
    installation directory was changed from the default of /usr/local,
    adapt the makefile using a text editor. Change the value of
    VRUI_MAKEDIR close to the beginning of the file as follows:
    VRUI_MAKEDIR := /share/make
    Where
    is the installation directory chosen in
    step 0. Use $(HOME) to refer to the user’s home directory instead
    of ~.

    I realize this may be a little confusing. What you need to do is edit the makefile of the Kinect package to say

    VRUI_MAKEDIR := /usr/local/share/Vrui-4.5/make

    instead of

    VRUI_MAKEDIR := /usr/local/share/Vrui-4.2/make

    While you’re at it, I recommend downloading Kinect-3.4 and SARndbox-2.4, which are the current versions of those packages.

    #114250

    devan
    Participant

    Thanks so much, Oliver! Worked perfectly and my students were SO excited to see the changes reflected in the installation instructions.

    Our kinect camera should arrive today via ebay and we’ll be off to the next step…..

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed.