Off-the-shelf desktop PC for AR Sandbox

Home Forums AR Sandbox Forum Off-the-shelf desktop PC for AR Sandbox

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by  tlw7409 2 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #111052

    Oliver Kreylos
    Keymaster

    I recently installed the AR Sandbox software on an off-the-shelf desktop PC, and everything went smoothly. I want to share the details as an option for those who don’t want to assemble their own PC from parts.

    I picked an HP Envy Desktop 750-530qd. During configuration, I selected the following options:

    • Natural Silver; Air Cooling Solution (65w Processor and 500w Power Supply)
    • NVIDIA® GeForce® GTX 1060 3G (this is important!)
    • 500 W Bronze efficiency power supply

    and left everything else at the (or changed it to the) cheapest settings. The total came out to be USD 878.99. There’s no special reason I picked the HP. It offered the option of a GeForce GTX 1060 GPU for a decent price, and was in stock.

    I downloaded Linux Mint 18.3 64-bit with MATE desktop as operating system and burned it onto a 2 GB USB stick I had lying around.

    Upon hooking up the PC, plugging in the USB stick with the Linux Mint install image, and turning it on, I immediately started pressing the Esc key repeatedly, about twice per second, until the boot selection menu showed up. As per the “Windows Tax,” this PC came with Windows 10 pre-installed, but I didn’t even bother booting into it once. I selected to boot from the USB stick in UEFI mode, which brought up the Live Mint environment after a few seconds. From there, I directly clicked on “Install Linux Mint.”

    I used all default options during the installation procedure, except enabling third-party hardware (to install the Nvidia driver later), and as a consequence disabling secure boot. I chose a simple password for later.

    As this particular AR Sandbox was supposed to run in “kiosk mode,” I chose to log in the installation user automatically. Again, I chose a simple password. This PC was meant to run as an applicance, therefore security was not a concern.

    Installation finished in a few minutes, after which I unplugged the USB stick and rebooted. I ended back up on the MATE desktop, where I selected “Drivers” from the Control Center. I entered the user account password, and checked the Nvidia driver from “NVIDIA Corporation.” I decided to leave the Intel firmware alone, ignored the error message that popped up during driver installation, and rebooted again. The Nvidia driver came up working without issues (checked by running nvidia-settings).

    Next I downloaded and ran Vrui’s Build-Ubuntu.sh script as described on Vrui’s download page. While the script was installing required system packages, a message about “secure boot” appeared (I expected this to show up during Nvidia driver installation, but whatever). I pressed the Tab key to highlight the “OK” button, hit Enter to confirm, pressed Tab again to highlight “Yes” in “Configure Secure Boot,” entered some simple password, pressed Tab to highlight “OK” and hit enter, entered the same password again, and confirmed again. Vrui installation succeeded and the spinning globe showed up. I rebooted at that point to apply the secure boot settings, but wasn’t asked for the password. Instead I ended up right back on the MATE desktop. I guess that just worked.

    I installed the Kinect and SARndbox packages without issue.

    At this point, I mopped up by disabling Bluetooth and Wi-Fi, disabled the “software compositing window manager” in the Control Center’s “Window Properties” applet, and started configuring the Kinect and AR Sandbox.

    I downloaded the Kinect’s intrinsic parameters by running

    sudo KinectUtil getCalib 0

    (using sudo as the Kinect package was installed in a system location by default), and the calibrated the Kinect’s depth lens using RawKinectViewer following the instructions in the Kinect package’s README file.

    After that, I followed the AR Sandbox set-up and calibration instructions, and was done. The AR Sandbox worked beautifully, with smooth water simulation. The graphics card didn’t break a sweat.

    #118523

    chengdusandbox
    Participant

    I bought a HP pavilion 690-056ccn gaming desktop(with GTX 1060 graphics card) and then installed the linux mint on it. And I went to the control center and installed nvidia-driver-390 (recommended) in driver manager of linux mint. But my problem is that there is no signal from HDMI of gtx 1060 and the projector have no any signal received from gtx 1060. I don’t know whether or not something wrong with the graphic card and the driver. By the way, When I execute ” glxinfo | grep vendor”, the screen shows that ” server glx vendor string: SGI, client vendor string: mesa project and SGI, OPENGL vendor string:VMWare,Inc.” DO you know how to figure out the solution?

    #118531

    Oliver Kreylos
    Keymaster

    “OPENGL vendor string:VMWare,Inc.”

    It looks like you installed Linux inside a virtual machine. That will not work, because Linux won’t be able to directly access the graphics card, hence no image over HDMI.

    #118733

    tlw7409
    Participant

    I saw this one today on Amazon for $700. I think this would run it all pretty smoothly?

    Gaming PC RGB Desktop Computer Intel i5-3570 3.40GHz, Ram 16GB,Hard Drive 2TB,Windows 10 Pro Video Card Nvidia GTX 1060 3GB VR Ready Ethernet and WiFi for Serous High End Gaming

    https://www.amazon.com/dp/B07NYBLWCH/ref=cm_sw_r_cp_api_i_NEBdDbY5TAQ4M

    Check it out and let me know what you think, computer nerds! 😂😂 (:

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.