please help for installation-fatal error, failed install Vrui

Home Forums AR Sandbox Forum please help for installation-fatal error, failed install Vrui

This topic contains 4 replies, has 3 voices, and was last updated by  mightymouse3062 8 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #103441



    please help me to fix following installation problem
    I followed the complete installation instructions, but failed on step 2,
    my linux Mint version is 1.8

    here is the content shows on terminal window:

    Compiling Vrui/Internal/ScreenProtectorArea.cpp…
    In file included from /home/ar/src/Vrui-4.2-006/Vrui/Internal/Linux/ScreenSaverInhibitorDBus.h:27:0,
    from Vrui/Internal/Vrui.General.cpp:86:
    /usr/include/dbus-1.0/dbus/dbus.h:29:33: fatal error: dbus/dbus-arch-deps.h: No such file or directory
    compilation terminated.
    /home/ar/src/Vrui-4.2-006/BuildRoot/BasicMakefile:128: recipe for target ‘o/g++-3.g0.O3/Vrui/Internal/Vrui.General.o’ failed
    make: *** [o/g++-3.g0.O3/Vrui/Internal/Vrui.General.o] Error 1
    make: *** Waiting for unfinished jobs….
    Compiling Vrui/Internal/UIManagerPlanar.cpp…
    make: *** wait: No child processes. Stop.
    Build unsuccessful; please fix any reported errors and try again
    ar@arsandbox ~ $



    Try sudo apt-get install libdbus-1-dev
    by the way this should have been installed by the, Are you using that to install and build Vrui?


    • This reply was modified 9 months, 2 weeks ago by  mishafarms.


    Dear Michael,

    thanks for your suggestion, I tried sodu apt-get install libdbus-1dev, however the system told me it already installed,
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    libdbus-1-dev is already the newest version (1.10.6-1ubuntu3.3).
    0 upgraded, 0 newly installed, 0 to remove and 271 not upgraded.

    can you tell me any other ways to fix it



    Try this command. It will tell you where it put the file.
    dpkg -L libdbus-1-dev

    here is the output of mine. I removed all the lines that are not the file
    we are looking at.


    If you find the file, then the issue becomes why is your compile not pointing to the correct directory to find it.
    You may have to compile with VERBOSE=1 and get all the output of the failed compile including the g++ command to compile.




    Good afternoon,
    I am trying to compile Vrui and hitting the same problem where it cannot find dbus-arch-deps.h

    /usr/include/dbus-1.0/dbus/dbus.h:29:33: fatal error: dbus/dbus-arch-deps.h: No such file or directory
     #include <dbus/dbus-arch-deps.h>

    I have verified that dbus-arch-deps.h lives in

    In I have modified this line

    to be


    and I have also tried a CFLAGS='-j4 INSTALLDIR=/usr/local -I /usr/lib/x86_64-linux-gnu/dbus-1.0/include/dbus' make and CFLAGS='-j4 INSTALLDIR=/usr/local -I /usr/lib/x86_64-linux-gnu/dbus-1.0/include' make

    All end up with the same error of not finding dbus-arch-deps.h. Since I am not the best with debugging compiler problems like this, any suggestions for a solution?

    Thank you

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Comments are closed.