Problem with calibration

Home Forums AR Sandbox Forum Problem with calibration

This topic contains 2 replies, has 2 voices, and was last updated by  Oliver Kreylos 3 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #100591

    jslakeviz
    Participant

    Our site is having problems w/performing calibration step 7. The key issues is that the target (created with a CD covered with white paper) is not recognized.
    More specifically, the target circle does not turn green (it remains yellow). The target was placed on top of an object and a wire was attached to the target and moved around the sand surface.
    Neither technique produced a green target.

    The NUC is not the final hardware solution, however, I just want to verify functionality before proceeding with better hardware.

    What calibration step would cause the round target not to be seen, therefore, not producing the green circle?

    Thanks in Advanced!

    Steps 1 & 2: SKIPPED
    Step 3: OK
    Step 4: OK Calibration
    Step 5: OK Calibration
    Step 6: OK
    Step 7: Problem with this calibration step, target is not detected.
    Step 8: Functional but projection is inverted due to the failure of Step 7

    Operating System: Ubuntu 14.04 LTS, set as 4:3 (1024 x 768)
    Hardware : http://us.hardware.info/reviews/4494/intel-nuc-dc53427hye-review-mini-means-business
    Projector : HDMI Project (don’t have brand at this time) set as 4:3
    Kinect : Model 1414

    Software Version:
    Vrui-3.1-002
    Kinect-2.8
    SARndbox-1.5

    The physical layout of the project and Kinect sensor is as shown in http://idav.ucdavis.edu/~okreylos/ResDev/SARndbox/index.html

    #100592

    jslakeviz
    Participant

    This link:
    http://lakeviz.org/forums/topic/corner-order-in-calibration-step-5/

    Stated that the in Step 5, the README document instructed to select points as:
    LL, LR, UL, UR
    However, the video showed the point selection as:
    LL, LR, UR, UL

    The correct selection is the README document.

    With this modification, I was able to get the green target.

    My last issues was when I ran the ./SARndbox (with no parameters). The contour lines
    were not in alignment with projector. The projection was inverted.

    This link: http://doc-ok.org/?p=164

    Stated to pass a parameter to the SARndbox program as follows:

    ./SARndbox -fpv

    I did not find this specified in the README.

    I am now up and running….

    #100593

    Oliver Kreylos
    Moderator

    “This link: http://doc-ok.org/?p=164

    Stated to pass a parameter to the SARndbox program as follows:

    ./SARndbox -fpv

    I did not find this specified in the README.”

    Yes, that was a mistake I made in the 1.5 package. Since you have run into that problem and found the solution, here is the relevant section of the README file that will go into the next release:

    “Step 8: Run the Augmented Reality Sandbox
    —————————————–

    At this point, calibration is complete. It is now possible to run the
    main Augmented Reality Sandbox application, SARndbox, in calibrated
    mode by passing the -fpv (“fix projector view”) option on the command
    line. This option will load the projector calibration matrix calculated
    in step 7, and disable manual navigation. Without the -fpv option, the
    scanned 3D terrain surface will be rendered as a typical 3D model, with
    full rotation, panning, and zooming ability, and will therefore not
    align properly with the physical sand surface.”

    Will that do the job?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed.