Problem with install/script

Home Forums AR Sandbox Forum Problem with install/script

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #102339
    pete eley
    Participant

    HI
    I’ve been trying to install a new sandbox but keep getting this error. Any help much appreciate

    arsandbox@arsandbox-System-Product-Name ~ $ cd ~
    arsandbox@arsandbox-System-Product-Name ~ $ wget http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/Build-Ubuntu.sh
    –2016-09-28 11:16:53– http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/Build-Ubuntu.sh
    Resolving idav.ucdavis.edu (idav.ucdavis.edu)… 169.237.153.125
    Connecting to idav.ucdavis.edu (idav.ucdavis.edu)|169.237.153.125|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: 4109 (4.0K) [text/x-sh]
    Saving to: ‘Build-Ubuntu.sh’

    Build-Ubuntu.sh 100%[=========================================================================================================================================>] 4.01K 21.5KB/s in 0.2s

    2016-09-28 11:16:54 (21.5 KB/s) – ‘Build-Ubuntu.sh’ saved [4109/4109]

    arsandbox@arsandbox-System-Product-Name ~ $ bash Build-Ubuntu.sh
    Please enter your password to install Vrui’s prerequisite packages
    [sudo] password for arsandbox:
    Sorry, try again.
    [sudo] password for arsandbox:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘libpng12-dev’ instead of ‘libpng-dev’
    Note, selecting ‘libtiff5-dev’ instead of ‘libtiff-dev’
    E: Unable to locate package libXi-dev
    E: Unable to locate package libXrandr-dev
    Problem while downloading prerequisite packages; please fix the issue and try again

    Thanks Pete

    #102342
    ebrownmn
    Participant

    Hello Pete. I wish I had an answer for you but I came here because I am getting the same error. I will be watching this thread too. If I find out how to fix it, I will let you know, and could you do the same? Thanks!

    Ellie

    #102343
    ndscs.lscet
    Participant

    I had the same issue, and what I ended up doing is installing the Vrui and the prerequisites through this link and it seemed to work. Hopefully this works for you.
    http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/LinkDownload.html

    #102352
    mcin8130
    Participant

    I had the same issue with the new version of Linux Mint. To fix, I just installed the packages manually:
    1. Run the wget command to download the SH file
    2. Try running the SH file, if you get errors for missing packages (libXi-dev and ibXrandr-dev), continue…
    3. Install libXi-dev and ibXrandr-dev packages individually in the command line
    4. Open the downloaded Build-Ubuntu.sh file from step 1 above
    5. Remove the two packages from the PREREQUISITE_PACKAGES list at the top of the file
    6. Save the file, and continue with install directions (bash Build-Ubuntu.sh)

    No more error messages during install, and everything seems to work (I haven’t encountered an error yet).
    I hope this helps,
    B

    #102358
    philip1000rr
    Participant

    I had the exact same issue. After downloading this build file:

    http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/Build-Ubuntu.sh

    I would run it and get this feedback:

    $ sudo bash Build-Ubuntu.sh
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘libpng12-dev’ instead of ‘libpng-dev’
    Note, selecting ‘libtiff5-dev’ instead of ‘libtiff-dev’
    E: Unable to locate package libXi-dev
    E: Unable to locate package libXrandr-dev

    Problem while downloading prerequisite packages; please fix the issue and try again

    I checked the build file and found a capitalization error on this line:

    PREREQUISITE_PACKAGES=”build-essential g++ libudev-dev libdbus-1-dev libusb-1.0-0-dev zlib1g-dev libpng-dev libjpeg-dev libtiff-dev libasound2-dev libspeex-dev libopenal-dev libv4l-dev libdc1394-22-dev libtheora-dev libbluetooth-dev libXi-dev libXrandr-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev”

    The letter ‘x’ in those two package names should be lowercase.

    I used vi to change the two package names to all lowercase:

    PREREQUISITE_PACKAGES=”build-essential g++ libudev-dev libdbus-1-dev libusb-1.0-0-dev zlib1g-dev libpng-dev libjpeg-dev libtiff-dev libasound2-dev libspeex-dev libopenal-dev libv4l-dev libdc1394-22-dev libtheora-dev libbluetooth-dev libxi-dev libxrandr-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev”

    After correcting the capitalization error and making the two file names all lowercase, the build file worked without issue.

    #102376
    Christina954
    Participant

    It worked for me. Thanks!

    • This reply was modified 3 years, 11 months ago by Christina954.
    #102391
    GG_MEDL
    Participant

    Changing the “X” to “x” in the Build-Ubuntu.sh file using Text Editor worked perfect.

    Never had this problem before, but I am testing out Linux Mint 18 and it has been a number of months since I downloaded the program. Not sure if it is because of Mint or the updated version. This was an easy fix though.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

Comments are closed.