Problem with OpenGL

Home Forums AR Sandbox Forum Problem with OpenGL

This topic contains 10 replies, has 3 voices, and was last updated by  Oliver Kreylos 2 days, 11 hours ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #115838

    Noriel_Sylvire
    Participant

    Well, I installed this software in a new computer because I need the other one for something else.
    So far the installation has been completed with no major issues but I encountered an error trying to run CalibrateProjector.
    This is a screenshot of the error I got. -google-site-with-uploaded-photo-
    So I guess the problem is my graphics card is not compatible with OpenGL or it needs a driver or is it something else?
    What should I do to solve this?

    #115839

    Oliver Kreylos
    Moderator

    Check for your graphics card model by running in a terminal:

    lspci | grep VGA

    Then check for OpenGL driver support by running in a terminal:

    glxinfo | grep vendor

    If the first command lists an Nvidia graphics card and the second one does not mention Nvidia, you need to install Nvidia’s proprietary driver as indicated in the installation instructions, step 2.

    #115869

    Noriel_Sylvire
    Participant

    Hello, sir.
    We have tried that, then reinstalled Linux Mint and tried again, now we are using a different computer and we got the same error so we reinstalled Mint, both for x86 and x64, and then tried using ubuntu. In all of these cases, the only driver listed was the processor microcode. In the first computer, the graphics card was an AMD Mobility Radeon HD 3150 and now we are using a computer with an Intel Xeon E3 1200.
    In this computer, when I execute lspci | grep VGA I get “00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)”
    Then, glxinfo | grep Vendor returns server glx vendor string: SGI
    client, glx vendor string: Mesa Project, and SGI
    OpenGL vendor string: Intel Open Source Technology Center
    I have asked on StackExchange, and someone told me this is not because I don’t have the necessary drivers installed, but because the software requests GL_EST_gpu_shader4 while our computer supports OpenGL version 3.3 (checked by running glxinfo | grep version)
    Can you help us with this?

    And also, there is one more thing, can I contact you in a more private way? I need to ask you something. Do you have an email you use for these kinds of things?

    #115871

    ferretvoice
    Participant

    have the same problem, do u solve this now?

    #115876

    Noriel_Sylvire
    Participant

    Not yet.

    #115879

    Oliver Kreylos
    Moderator

    OK, your problem is that your computer doesn’t have a (dedicated) graphics card, but is using the integrated graphics processor (IGP) that’s part of modern Intel CPUs. You got bad information from StackExchange; the “4” in GL_EXT_gpu_shader4 is not an OpenGL version number, but a version number for that specific OpenGL extension. It just so happens that the IGP in your specific Intel CPU doesn’t support it — not surprising, as it is meant for “business graphics” and not serious 3D work.

    CalibrateProjector’s use of that extension snuck into the newest AR Sandbox software version unintentionally. Try downgrading to version 2.3 of SARndbox and see if that works, but in the best case, without a dedicated graphics card, the AR Sandbox won’t be able to support water simulation. You’ll have to turn that off by passing -ws 0 0.0 to SARndbox’s command line.

    #115889

    Oliver Kreylos
    Moderator

    Actually, don’t downgrade the Kinect package.

    Instead, upgrade to version 3.6 of the Kinect package, which checks if GL_EXT_gpu_shader4 is supported by the local OpenGL and, if not, falls back to a facade projector that does not use it.

    Download and install Kinect-3.6 per step 4 of the installation instructions, and then re-build your SARndbox package:

    cd ~/src/SARndbox-2.5
    make clean
    make

    Then run CalibrateProjector again. You still won’t get water simulation, though.

    • This reply was modified 3 weeks, 1 day ago by  Oliver Kreylos. Reason: Oops, bad instructions
    • This reply was modified 3 weeks, 1 day ago by  Oliver Kreylos. Reason: New Kinect package version
    #115903

    Noriel_Sylvire
    Participant

    Oh, right thank you, I will do exactly this Wednesday.
    Thanks a lot, Oliver!

    #115917

    Noriel_Sylvire
    Participant

    Hello, Oliver. I’ve done that and it works marvel! Only one little issue here. As you told me we can’t use water, which is not great. Isn’t there any way of using it? I’ve set the water resolution to a low value via -wts 200 150, so that it down’t use a lot of resources. But it’s still not working.
    Does this mean that we wont be able to use water?

    #115918

    Noriel_Sylvire
    Participant

    Can’t we use the cursor to make water?

    #115941

    Oliver Kreylos
    Moderator

    No, if your graphics card and/or drivers do not support water simulation, you cannot use water simulation.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Comments are closed.