Projector/Calibration Prbolem. error reading Boxlayout.txt

Home Forums AR Sandbox Forum Projector/Calibration Prbolem. error reading Boxlayout.txt

This topic contains 3 replies, has 2 voices, and was last updated by  Oliver Kreylos 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #115611

    rbarshick1
    Participant

    I’m trying to do the step where we calibrate the Kinect and the projector together, but when i run the commands, it tells me that there is an error reading the text file. It says it is unable to open file /ect/SARndbox-2.4/BoxLayout.txt for reading error 2. BoxLayout.txt is in the correct folder and path, its named correctly, and has the proper coords in it. But for some reason the calibration projector doesn’t seem to be able to read or find the file.
    I’ve seen this on the forum many times with no response or solutions, Any help would be welcome

    #115622

    Oliver Kreylos
    Moderator

    You might be in the wrong directory when trying to run CalibrateProjector. Did you follow the instructions precisely?

    cd ~/src/SARndbox-2.4
    ./bin/CalibrateProjector -s 1024 768

    (Replace “1024 768” with your projector’s actual pixel size.)

    #115628

    rbarshick1
    Participant

    Yes i was definitely in the right directory. I figured out the problem.
    The problem is, whoever updated the calibrate projector program last.
    Instead of reading BoxLayout.txt from /src/SARndbox-2.4/etc/SARndbox-2.4/BoxLayout.txt,
    it’s reading it from /etc/SARndbox-2.4/BoxLayout.txt in the system files.
    So i had to move the BoxLayout.txt to that SARndbox folder in the system files etc and CalibrateProjector worked like a charm.

    I’m just guessing whoever updated the software last made a mistake in setting the path for the software to read that .txt file.
    I haven’t seen any other solution to this problem on the forums so i hope this helps anyone else who has this problem. If anyone needs the specific commands for moving the file and editing it, i will gladly provide them

    #115629

    Oliver Kreylos
    Moderator

    That happens when you accidentally build the SARndbox package with

    make INSTALLDIR=

    or if you accidentally changed the makefile line

    INSTALLDIR := $(PWD)

    to

    INSTALLDIR :=

    or removed that line completely.

    As this will cause you problems later, I recommend checking that the makefile is correct, and re-building the package exactly as in the instructions:

    cd ~/src/SARndbox-2.4
    make

    You can check the result by looking into Config.h. It should contain the line

    #define CONFIG_CONFIGDIR "/home/<username>/src/SARndbox-2.4/etc/SARndbox-2.4"

    where you previously had

    #define CONFIG_CONFIGDIR "/etc/SARndbox-2.4"

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.