Sandbox 2.2

Home Forums AR Sandbox Forum Sandbox 2.2

This topic contains 8 replies, has 6 voices, and was last updated by  ryanwildevans 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #102430

    ndscs.lscet
    Participant

    I upgraded from 1.6 to 2.2, and I did the updates for Vrui and Kinect, but when I run 2.2 the surface is white with contour lines and there is no elevation colors. Also the water simulation does not work. I am still able to run 1.6 though. Any ideas on what went wrong or what I need to do?

    #102436

    sharned
    Participant

    Try adding the -uhm switch when you run the SARndbox software. I saw the same thing when I took that switch out of the script I had run version 1.6 from.

    I also noticed that the Rain Cloud function and Local Water Management do not seem to work. I am not sure whether I’ve set something wrong, or it’s a problem in the new version. Hope it gets fixed soon, we have a demo in about 10 days and I’d like to use version 2.2.

    #102442

    ndscs.lscet
    Participant

    I was able to get it to work by uninstalling everything and reinstalling all of it, but when I ran it I could not make it rain with my hand but it would work when I used the water tool. As soon as I used my shortcuts for different shaders (which I did update to the new path) all the water went away and I cant get it back. Any ideas on what I am doing wrong or is this a issue with the new release?

    #102447

    11tale
    Participant

    I am having similar problems with 2.2. The color works when I use the -uhm switch, but I have not been able to make the rain cloud function work. I am able to get global rain by using the water tool. I do not experience any of these problems when running 1.6.

    #102449

    Oliver Kreylos
    Keymaster

    I might have forgotten some default settings when updating to the new way of doing multi-window settings management.

    To get the height color map as before, add -uhm to SARndbox’s command line.

    To get rain working, please try adding -rer 20 100 to set the elevation range for rain clouds. Also, SARndbox 2.2 looks for a specific gesture to make rain: Hold out your hand flat above the terrain, ideally palm down, and spread all five fingers.

    #102459

    ndscs.lscet
    Participant

    That worked great. Thanks for all your help and the great product you have created.

    #102466

    marco.afp
    Participant

    Hi!

    After the updated to 2.2 I’ve been using the command “./bin/SARndbox -uhm -fpv -rer 20 100” but the rain is still not working. Maybe the range is not right – how to set it?

    Thanks a lot!

    #102472

    sharned
    Participant

    Through experimentation on the 2.2 version, I have found that the -rer values are reversed and should be MAX MIN (not MIN MAX) so I use -rer 80 30 and it seems to work fine.

    #102756

    ryanwildevans
    Participant

    I uninstalled everything and reinstalled the most updated version once again. Every thing works great until I get to the point to make my shortcuts to the shaders and then the water goes away!

    Even when I hit the flood button, nothing happens.

    I have tried -rer 20 100 and -rer 80 30. Cant get the water back unless I uninstall and reinstall.

    Has anyone found a fix for the Sandbox 2.3? Ugh! Thanks for any help!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed.