Sandbox crash into light blue screen with stripes

Home Forums AR Sandbox Forum Sandbox crash into light blue screen with stripes

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #112791


    We have a problem with Sandbox crashing into a light blue screen with stripes, see this photo:
    IMG 0461 002

    When booting the system it works and the software sometimes crash 10 minutes after start (there is no activity in the sandbox) sometimes it works for hours without an crash.

    Is there a solution to the cause of these crashes? Or is there a workaround to reboot the pc or software when a crash occurs?

    Linux Mint version 18.3 mate 64 bits

    PC: Intel Core i7−7700, 8Gb RAM, GiBy3GB D5 GTX 1060 G1, SSD 256GB
    Projector: Casio XJ-V2 1024x768px projector

    We using the following startup command in “startup applications preferences”:
    bash -c "sleep 30 && ./src/SARndbox-2.3/bin/SARndbox -uhm -fpv -er -15 10 -ws 0.8 30 -rs 0 -mergeConfig ./src/SARndbox-2.3/bin/Vrui.cfg

    We run Teamviewer for remote access

    • This topic was modified 3 years, 1 month ago by Jaap57.

    My guess is the Kinect crashed either the driver stops getting frames from it or the hardware causes it. I occasionally get that type of screen on startup, maybe some race condition. I also do a 30 second sleep but that doesn’t prevent all the crashes at boot, just making it less often. I wish there were a solution. If this is a setup you made for someone else, place a short cut on the desktop so they can quit the sandbox and restart it easily.


    Is there a way to restart the sandbox automatically when a crash occurs? Or when it is not used for a time?


    That probably requires changes to the source code. Last time I tried to add some features to the code it took a lot of effort and help from Dr. Kreylos. I imagine the code needs to recognize the Kinect is not supplying correct frames and then restart.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Comments are closed.