Sandbox image distortion – Kinect 1414

Home Forums AR Sandbox Forum Sandbox image distortion – Kinect 1414

This topic contains 1 reply, has 2 voices, and was last updated by  Oliver Kreylos 1 month, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #118513

    bwbingham
    Participant

    I am so close to getting this up and running. I have ran through all the steps and when I go to run the sandbox the projected image does not run the way it should. I do not know if its the calibration process (which I ran exactly the way Oliver mentioned in his steps) or if its an issue with the version of Kinect camera I have, the first generation 1414. I even followed step 6a as a way to improve the per-pixel depth correction. Please take a look at these images and tell me whats going on?

    https://drive.google.com/file/d/0B-VYlxykUJCrUUY5VWljUVJxdExOQi1NV0xhemZGRl8zbjZR/view?usp=sharing

    https://drive.google.com/file/d/0B-VYlxykUJCrTGxlTFV0QzZEbmQ5bkktc3pEa3NqcVdDSGQ0/view?usp=sharing

    #118567

    Oliver Kreylos
    Keymaster

    I’ve never seen that before. It looks like your Kinect is reporting wrong intrinsic calibration parameters. Try running “sudo KinectUtil -getCalib 0” again, and (temporarily) remove your depth calibration parameters from the Kinect package’s configuration directory (by default /usr/local/Vrui-<version>/Kinect-<version>).

    Then run “KinectViewer -compress -c 0” (not RawKinectViewer) and see if you are getting an undistorted 3D reconstruction of your environment.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.