Sandbox "in a well" — need help!

Home Forums AR Sandbox Forum Sandbox "in a well" — need help!

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #102278
    sylvestera
    Participant

    First let me say — I have enjoyed start sandbox -fpv is a blackARSANDB0X
    very much– Until today.

    I successfully built my own ARsandbox and am building
    one for the school but have A Problem. the Raw Kinect looks normal and Calibrate projection goes fine… But what I get when I start sandbox (-fpv) is a black rectangle at the bottom of a pit and all objects appear severely stretched.

    HELP?

    I have recalibrated the Box…txt file and run CalibrateProjector multiple times

    #102279
    sylvestera
    Participant

    A link to a picture of what I’m getting:
    https://www.dropbox.com/s/y7dyr6co2wvb2e6/IMG_1655.JPG?dl=0

    #102280
    GrantWells
    Participant

    Hi, hey at a guess it looks like your kinect Z height is way off, maybe there’s an error in your BoxLayout.txt, or the camera plane is used rather than base plane equation?

    The text needs minor reformating from the terminal window into the boxlayout file so given you’ve already built a box before then I’d be looking for a ‘too obvious to see’ transcribing error – the boxlayout structure is covered here: https://youtu.be/EW2PtRsQQr0?t=367

    rgds
    Grant

    #102285
    sylvestera
    Participant

    Thank you! Good call! That’s exactly what it was!
    Got it working, here’s the issue-

    The projector I am using is such that for the image to be big enough to be useable, the projector has to be about 5 feet above the sand surface, and that is apparently beyond the “seeing” of the Kinect (which was attached “piggy back” style on the projector itself).

    I solved this by placing the projector on a horizontal surface and bouncing the image off a mirror onto the sand surface, which allows the Kinect to be much closer to the sand surface (dangling from the bottom of the mirror-holder….and viola! All is well again!

    For future reference, this was a Promethean PRM-10 projector – avoid!

    Many thanks!

    #102286
    GrantWells
    Participant

    😉 good news.

    Hmm.. my projector is a promethean PRM-30, and my kinect must be pushing 5′ also. Maybe thats the source of my calibration issues.. Glad it worked out.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Comments are closed.