Sandbox Make Error

Home Forums AR Sandbox Forum Sandbox Make Error

Tagged: 

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #124462
    kcpiper
    Participant

    So I am very new to all of this. I tried installing following all the directions and received an error in Step 5: Install the Augmented Reality Sandbox. I crossed my fingers that it wasn’t all that important and was able to move on to the rest of the integration, configuration, and calibration steps.

    SARndbox-2.7.tar.gz.1 100%[==================================>] 129.53K 564KB/s in 0.2s

    2020-06-12 15:27:49 (564 KB/s) – ‘SARndbox-2.7.tar.gz.1’ saved [132640/132640]

    kpiper@EarthExplorer:~/src$ tar xfz SARndbox-2.7.tar.gz
    kpiper@EarthExplorer:~/src$ cd SARndbox-2.7
    kpiper@EarthExplorer:~/src/SARndbox-2.7$ make
    —- SARndbox installation configuration —-
    Root installation directory: /home/kpiper/src/SARndbox-2.7
    Configuration data directory: /home/kpiper/src/SARndbox-2.7/etc/SARndbox-2.7
    Resource data directory: /home/kpiper/src/SARndbox-2.7/share/SARndbox-2.7
    Shader source code directory: /home/kpiper/src/SARndbox-2.7/share/SARndbox-2.7/Shaders
    —- End of SARndbox configuration options: —-
    Compiling CalibrateProjector.cpp…
    Linking bin/CalibrateProjector…
    Compiling ShaderHelper.cpp…
    Compiling ElevationColorMap.cpp…
    Compiling SurfaceRenderer.cpp…
    Compiling Sandbox.cpp…
    Linking bin/SARndbox…
    /usr/bin/ld: _ZN23GLARBVertexBufferObject7currentE: TLS reference in o/g++-3.g0.O3/DepthImageRenderer.o mismatches non-TLS reference in /usr/local/lib/x86_64-linux-gnu/Vrui-5.2/libGLGeometry.g++-3.so
    /usr/bin/ld: /usr/local/lib/x86_64-linux-gnu/Vrui-5.2/libGLGeometry.g++-3.so: error adding symbols: bad value
    collect2: error: ld returned 1 exit status
    make: *** [/usr/local/share/Vrui-5.2/make/BasicMakefile:244: bin/SARndbox] Error 1

    However, when I tried Step 12: Run the AR Sandbox, I received an error.

    kpiper@EarthExplorer:~/src/SARndbox-2.7$ cd ~/src/SARndbox-2.7
    kpiper@EarthExplorer:~/src/SARndbox-2.7$ ./bin/SARndbox -uhm -fpv
    bash: ./bin/SARndbox: No such file or directory

    Any pointers to what I am doing wrong? I tried redoing the steps from the beginning, but still got the same errors. Thanks!

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Comments are closed.