Sandbox on $99 Jetson Nano

Home Forums AR Sandbox Forum Sandbox on $99 Jetson Nano

This topic contains 0 replies, has 1 voice, and was last updated by  bdazzler 2 months, 3 weeks ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #118844

    bdazzler
    Participant

    I tried running the AR Sandbox on the $99 Jetson Nano board and was pleasantly surprised.

    Building the software was straightforward apart from getting this error when building vrui:
    /usr/include/dbus-1.0/dbus/dbus.h:29:10: fatal error: dbus/dbus-arch-deps.h: No such file or directory
    … which I was able to work around by adding this line to the makefile:
    CFLAGS += $(shell pkg-config --cflags dbus-1)

    I don’t (yet) have an actual sandpit/projector/mounts, but just pointing the Kinect at the wall and playing with the commandline arguments I got something that looked encouraging enough to carry on with the project. I ended up with this commandline:
    ./bin/SARndbox -ncl –uhm –wts 160 120 –ws 1.5 15 –nas 10 –rs 1.5

    I haven’t tried calibration yet, this was just literally pointing the Kinect at the wall & running the program.

    I’m interested to know whether anyone else has tried this? The Nano might be low-powered enough to run from a battery, so I was wondering about trying a mini LED projector for a fully-battery-powered / portable AR Sandbox. I know the mini LED projectors are low-lumen output, but they’re also very cheap and might bring this project within budget for some people.

Viewing 1 post (of 1 total)

The forum ‘AR Sandbox Forum’ is closed to new topics and replies.

Comments are closed.