Segmentation fault – Help

Home Forums AR Sandbox Forum Segmentation fault – Help

This topic contains 3 replies, has 2 voices, and was last updated by  Ross 3 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #101313

    plapke
    Participant

    Hello,
    First, I wanted to say thanks for providing all of this for everyone to be able to use. It is really an incredible project.

    I have followed the instructions on here and everything seems to work well, I go through the calibration and everything, but when I go to run ./bin/SARndbox -uhm -fpv it throws the “segmentation fault”

    So I looked through all the posts here and saw that I should try it with the water disabled. so I tried

    ./bin/SARndbox -fpv -ws 0.0 0

    still throws the “segmentation fault”

    I have tried every combination of ./bin/SARndbox I could think of…

    ./bin/SARndbox
    ./bin/SARndbox -fpv
    ./bin/SARndbox -uhm
    ./bin/SARndbox -ws

    etc.

    Nothing really worked. A couple times a different error popped up, but I figured that was just because I did a bad combo of the ./bin/SARndbox.

    So I went back and tried the ./bin/SARndbox -uhm -fpv and it tried to work…and by that I mean that it displayed some large blue and green “contour” lines, (though it wasn’t what was in the box, it was just large diagonal lines. But if I clicked on anything with the mouse it crashed and shows the “segmentation fault” again.

    Any ideas? Like I said all the steps leading up to this work fine. I am running on integrated graphics, so that may be the problem right there, but I thought it would just be slower not crash it.

    Thanks for any help in advance.

    #101829

    plapke
    Participant

    Anyone have any thoughts on this? I was forced to step away from the project but am going to come back to it now to try and make it work. Any help would be greatly appreciated.

    Thanks

    #101831

    Ross
    Participant

    Iḿ no expert, but reading through the forum indicates that the system will not function correctly if at all on an on board graphics card. I think you need to consider the age of the PC, i.e. the technology it uses is the video driver open GL being run in software emulation mode.
    Which linux are you using? Mint 17.3 is out I recommend it over ubuntu, if you need to use ubuntu I would do a fresh install
    What Processor are you using?
    Whats the relative capability of your on boards graphics compared with a middle of the road solution Geforce 770, 960 and the like?

    I did my initial build on a Dell precision m6400 workstation with a dedicated video card the Quadro FX 2700M 512mb, 8 gig Ram and Intel® Core™2 Duo CPU T9600 @ 2.80GHz, The Sand box runs while the water chokes everything.
    With the water on the CPU, both cores max at 100% and cannot supply the graphics card quick enough it runs at only 14%, when the water is switched off it the CPU runs at a more healthy 58% both cores when redrawing and the graphics processor at 46%.
    At the end of the day the graphics speed is probably limited by the number of cores in the GPU The quatro has 48 The geforce 960 1024 a factor of 50 difference.

    The laptop based quatro allows me to test the system but in my opinion it is not suitable for a system you would want for public use. For personal use the contour repainting is ok a bit sluggish but given it repaints only small sectors of sand at a time and most of the waiting time is due to heavy filtration then itś surprisingly good.
    There are other factors at work with open GL Iḿ sure I read on the forum (but can´t find it now) the sandbox requires an up to date revision to function.

    Hope this non specific ramble helps

    #101832

    Ross
    Participant

    Managed to replicate your Segmentation fault at the moment Iḿ not sure how, I was working in three areas with the control.fifo pipe and using an hd projector at various resolutions.

    Terminal

    I used Olivers new Pipe see the minor software revision for details – http://lakeviz.org/forums/topic/minor-software-update/ — the command was executed and the sandbox started as per requirement with the Water Simulation set to zero.

    Hope this helps

    • This reply was modified 3 years, 4 months ago by  Ross.
    • This reply was modified 3 years, 4 months ago by  Ross.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.