trouble installing AR Sandbox

Home Forums AR Sandbox Forum trouble installing AR Sandbox

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #102916
    jefflgross
    Participant

    I get the message below when trying to install sandbox. I am new to linux and have no clue.
    This is the last line I see when the script stops.

    Caught exception Vrui::startDisplay: Could not create all rendering windows while initializing rendering windows
    jeff@jeff-N56JR ~ $

    My System

    Release Linux Mint 18.1 Serena 64-bit
    Kernel Linux 4.4.0-53-generic x86_64
    MATE 1.16.1
    Memory:11.6 GB@
    Processor: Intel Core i7- 4700HQ CPU@ 2.40GHz x 8
    ASUS Laptop AS N56jr

    Below is the entire script.

    jeff@jeff-N56JR ~ $ cd ~
    jeff@jeff-N56JR ~ $ wget http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/Build-Ubuntu.sh
    –2017-01-13 14:12:21– http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/Build-Ubuntu.sh
    Resolving idav.ucdavis.edu (idav.ucdavis.edu)… 169.237.153.125
    Connecting to idav.ucdavis.edu (idav.ucdavis.edu)|169.237.153.125|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: 4572 (4.5K) [text/x-sh]
    Saving to: ‘Build-Ubuntu.sh’

    Build-Ubuntu.sh 100%[===================>] 4.46K –.-KB/s in 0.04s

    2017-01-13 14:12:21 (100 KB/s) – ‘Build-Ubuntu.sh’ saved [4572/4572]

    jeff@jeff-N56JR ~ $ bash Build-Ubuntu.sh
    Please enter your password to install Vrui’s prerequisite packages
    [sudo] password for jeff:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘libpng12-dev’ instead of ‘libpng-dev’
    Note, selecting ‘libtiff5-dev’ instead of ‘libtiff-dev’
    build-essential is already the newest version (12.1ubuntu2).
    g++ is already the newest version (4:5.3.1-1ubuntu1).
    libasound2-dev is already the newest version (1.1.0-0ubuntu1).
    libbluetooth-dev is already the newest version (5.37-0ubuntu5).
    libglu1-mesa-dev is already the newest version (9.0.0-2.1).
    libjpeg-dev is already the newest version (8c-2ubuntu8).
    libpng12-dev is already the newest version (1.2.54-1ubuntu1).
    libspeex-dev is already the newest version (1.2~rc1.2-1ubuntu1).
    libtheora-dev is already the newest version (1.1.1+dfsg.1-8).
    libtiff5-dev is already the newest version (4.0.6-1).
    libusb-1.0-0-dev is already the newest version (2:1.0.20-1).
    libv4l-dev is already the newest version (1.10.0-1).
    libxi-dev is already the newest version (2:1.7.6-1).
    libxrandr-dev is already the newest version (2:1.5.0-1).
    zlib1g-dev is already the newest version (1:1.2.8.dfsg-2ubuntu4).
    libdc1394-22-dev is already the newest version (2.2.4-1).
    libopenal-dev is already the newest version (1:1.16.0-3).
    libdbus-1-dev is already the newest version (1.10.6-1ubuntu3.1).
    libgl1-mesa-dev is already the newest version (11.2.0-1ubuntu2.2).
    libudev-dev is already the newest version (229-4ubuntu13).
    mesa-common-dev is already the newest version (11.2.0-1ubuntu2.2).
    0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
    Creating source code directory /home/jeff/src
    mkdir: cannot create directory ‘src’: File exists
    Downloading Vrui-4.2-006 into /home/jeff/src
    –2017-01-13 14:14:33– http://idav.ucdavis.edu/~okreylos/ResDev/Vrui/Vrui-4.2-006.tar.gz
    Resolving idav.ucdavis.edu (idav.ucdavis.edu)… 169.237.153.125
    Connecting to idav.ucdavis.edu (idav.ucdavis.edu)|169.237.153.125|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: 3155651 (3.0M) [application/x-gzip]
    Saving to: ‘STDOUT’

    – 100%[===================>] 3.01M 1.44MB/s in 2.1s

    2017-01-13 14:14:36 (1.44 MB/s) – written to stdout [3155651/3155651]

    Building Vrui on 8 CPUs
    Libudev library exists on host system
    RawHID library enabled
    Multithreaded rendering disabled
    Default GL font directory: /usr/local/share/Vrui-4.2/GLFonts
    PNG image file format enabled
    JPG image file format enabled
    TIFF image file format disabled
    ALSA sound device support enabled
    SPEEX speech compression support enabled
    Video4Linux2 video device support enabled
    FireWire DC1394 video device support enabled
    Theora video codec support enabled
    Spatial sound using OpenAL enabled
    Swapgroup support for Vrui windows disabled
    Support for screen saver inhibition via DBus enabled
    Vrui will save screenshots in PNG format
    Support for spatial audio enabled
    Support to save screen captures in Ogg/Theora format enabled
    Support for multitouch screens enabled
    Support for named video outputs enabled
    LatencyTester vislet for Oculus DK1 latency tester enabled
    Using global per-user configuration file .config/Vrui-4.2/Vrui.cfg
    Event device support for joysticks disabled
    Bluetooth support (for Nintendo Wii controller) enabled
    USB support (for Razer Hydra and Oculus Rift tracker) enabled
    OpenVR SDK or SteamVR run-time do not exist on host system; support for HTC Vive disabled
    —- Vrui installation configuration —-
    Root installation directory : /usr/local
    Header installation root directory : /usr/local/include/Vrui-4.2
    Library installation root directory : /usr/local/lib/x86_64-linux-gnu/Vrui-4.2
    Executable installation directory : /usr/local/bin
    Plug-in installation root directory : /usr/local/lib/x86_64-linux-gnu/Vrui-4.2
    Configuration file installation directory : /usr/local/etc/Vrui-4.2
    Shared file installation root directory : /usr/local/share/Vrui-4.2
    Makefile fragment installation directory : /usr/local/share/Vrui-4.2
    Build system installation directory : /usr/local/share/Vrui-4.2/make
    pkg-config metafile installation directory: /usr/local/lib/x86_64-linux-gnu/pkgconfig
    Documentation installation directory : /usr/local/share/doc/Vrui-4.2
    —- End of Vrui configuration options —-
    Creating application makefile fragment…
    Creating configuration makefile fragment…
    Creating pkg-config meta data file…
    Configuring template makefile…
    Configuring makefile in ExamplePrograms…
    Configuring makefile in ExamplePrograms/MeshEditor…
    Configuring makefile in ExamplePrograms/VRMLViewer…
    Build successful; installing Vrui in /usr/local
    Please enter your password to install Vrui in /usr/local
    Installing header files in /usr/local/include/Vrui-4.2…
    Installing libraries in /usr/local/lib/x86_64-linux-gnu/Vrui-4.2…
    Configuring run-time linker…
    Installing executables in /usr/local/bin…
    Installing plug-ins in /usr/local/lib/x86_64-linux-gnu/Vrui-4.2…
    Installing configuration files in /usr/local/etc/Vrui-4.2…
    Retaining existing /usr/local/etc/Vrui-4.2/Vrui.cfg
    Retaining existing /usr/local/etc/Vrui-4.2/VRDevices.cfg
    Installing shared files in /usr/local/share/Vrui-4.2…
    Installing application makefile fragment in /usr/local/share/Vrui-4.2…
    Installing build system in /usr/local/share/Vrui-4.2/make…
    Installing pkg-config metafile in /usr/local/lib/x86_64-linux-gnu/pkgconfig…
    Installing documentation in /usr/local/share/doc/Vrui-4.2…
    Installation in /usr/local successful; installing device permission rules in /etc/udev/rules.d
    If prompted, please enter your password again to install device permission rules
    Installing udev rules into /etc/udev/rules.d…
    Building Vrui example programs on 8 CPUs
    make: Nothing to be done for ‘all’.
    Build successful; installing Vrui example programs in /usr/local
    If prompted, please enter your password again to install Vrui’s example applications in /usr/local
    Installing Vrui example programs in /usr/local…
    Running ShowEarthModel application. Press Esc or close the window to exit.
    Caught exception GLContext: GLX extension not supported on display :0 while initializing rendering window 0
    Caught exception Vrui::startDisplay: Could not create all rendering windows while initializing rendering windows
    jeff@jeff-N56JR ~ $

    #102919
    Oliver Kreylos
    Keymaster

    Caught exception GLContext: GLX extension not supported on display :0 while initializing rendering window 0

    This means that GLX, the X Window System binding for OpenGL, is not found on the local computer. Did you install the vendor-supplied drivers for your laptop’s Nvidia GeForce graphics card, and then reboot the computer to activate the drivers?

    Please run
    glxinfo
    and look for “server glx vendor string” and “OpenGL vendor string” (should both be “NVIDIA Corporation”) and “OpenGL version string” which should be something like “3.3.0 NVIDIA 340.98.”

    It is also possible that your laptop uses Nvidia’s Optimus technology to switch between the GeForce graphics card and the graphics adapter built into its Intel Core CPU. If that’s the case, it will get complicated. Optimus is nominally supported under Linux, but it needs to be set up manually. There is some background information in this somewhat outdated article, and setup instructions for Arch Linux that should be applicable to Ubuntu / Linux Mint in this post.

    #103494
    Anonymous
    Inactive

    I am getting the same error. When I run glxinfo I get the following information:

    name of display: :0
    Error: couldn't find RGB GLX visual or fbconfig

    This is not what I expected based on the message above. What should I do?
    -Shelley

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Comments are closed.