Trouble making rain

Home Forums AR Sandbox Forum Trouble making rain

This topic contains 6 replies, has 2 voices, and was last updated by  Trudpert 4 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #100870

    Trudpert
    Participant

    First, I want to thank you for your work in the augmented reality realm. It is amazing to say the least. I am currently setting up an Augmented Reality Sandbox. All of the forum discussions have been extremely helpful and I am really close to getting this up and running. However, after calibrating properly, the only thing I am missing is how to make it rain. I have assigned a Manage Water key (and then a Dry key), but those are not working. We are running on Ubuntu 14.04. I have all of the most recent downloads (Kinect, SARndbox, etc. ) and cannot figure out what I am missing.
    Here is what is currently happening. I am assigning the Manage water key to the number 1 and the dry key to the number 2. When I press and hold the 1 key (and put my hand over the display), no rain falls. I don’t know if I am assigning it correctly, or missing some crucial step in telling the software to create rain.
    I looked at all the forums and came across one person that was having the same issue and fixed it with a graphics driver. We have updated the graphics driver that came with the computer, but are still getting GL errors (specifically 1286, but other times it’s just an unknown error) This is the only thing stopping our installation. Please advise when you have a chance. Thank you in advance, and thanks again for all the work you are doing.

    #100871

    Oliver Kreylos
    Keymaster

    I’ll need a little more information. Would you please post the contents of your BoxLayout.txt file, and the output from

    glxinfo | grep vendor

    and the make/model of your graphics card?

    #100873

    Trudpert
    Participant

    BoxLayout…
    (0.0072524, -0.00339155, 0.999968), -135.561
    ( -58.4018, -27.972, -134.784)
    ( 58.1356, -29.8405, -136.914)
    ( -58.062, 39.2945, -135.083)
    ( 59.1808, 39.8853, -135.496)

    and I hope this one is correct. I don’t know Linux and hope I entered the right command…

    00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
    Subsystem: Dell Device [1028:0611]
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915

    The graphics card is the one that came with the computer.

    Intel 4400 series

    Please let me know if you need more information.

    #100883

    Oliver Kreylos
    Keymaster

    Intel Corporation Xeon E3-1200

    This is an Intel HD Graphics P3000. The reason you’re not seeing water at all is a problem between the AR Sandbox software and the open-source Mesa OpenGL graphics library, and a driver update might fix that, but even then, the P3000 will not be powerful enough to run the water simulation in any meaningful way.

    #100892

    Trudpert
    Participant

    I installed a new graphics card (PNY Nvidia Geforce GT 730 2 GB edition) and the proper drivers and reinstalled all of the software, following your installation guide. We have the latest editions of all software. The Show Earth Model is working well, the RawKinectViewer is working well. The SARndbox program is extremely slow to the point where we are holding a button to assign manage water and the menu isn’t coming up for a couple seconds.

    The computer has 8 GB of RAM, an i5 processor, and a terabyte of hard drive.

    In one of the forums, you talked about running a less accurate water simulation, for the sake of speed, but there wasn’t a mention of how to do that, and I haven’t found that information anywhere else. With this scenario in mind, what are my options to make the program run faster and still have a water simulation?

    #100895

    Oliver Kreylos
    Keymaster

    There are different models of the GT 730 with vastly different capabilities. Please run nvidia-settings, go to the “GPU 0 – (<GPU name>)” tab, and either post a screenshot, or the following important specifications:

    • Graphics Processor
    • CUDA Cores
    • Total Dedicated Memory
    • Memory Interface
    • Bus Type
    • PCIe Generation
    • Maximum PCIe Link Width

    For example, for my GPU, the values are (in order): GeForce GTX 680, 1536, 2048MB, 256-bit, PCI Express x16 Gen2, Gen2, x16.

    In the meantime, you can experiment by reducing the spatial resolution of the water simulation via the -wts <width> <height> command line argument. The default values are 640 and 480; try 320 and 240 first, and probe from there.

    Re: low-fi water simulation. I mentioned this as an alternative and future option, but it doesn’t exist at this moment.

    #100898

    Trudpert
    Participant

    Using the -wts command worked. Thank you for the information and dedication. Our interactive is up and running successfully. I’m sure we will come across other issues, but for now, I’m off to play in the sand.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Comments are closed.