Unable to compile VRUI, receive error /usr/bin/ld: cannot fi

Home Forums AR Sandbox Forum Unable to compile VRUI, receive error /usr/bin/ld: cannot fi

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #102243
    skippy1976uk
    Participant

    I am trying to build VRUI as part of the AR Sandbox build. I”ve tried download VRUI seperatly and buidling but also still get the same error:

    Building Vrui on 8 CPUs
    —- Vrui configuration options: —-
    Run-time library search paths enabled
    Threads library has built-in thread-local storage
    Threads library uses built-in atomics
    Threads library uses POSIX spinlocks
    Libusb library version 1.0 exists on host system
    Realtime library uses timers
    Multithreaded rendering disabled
    Local pthread implements pthread_cancel
    Libusb library supports bus topology queries
    PNG image file format enabled
    ALSA sound device support enabled
    JPG image file format enabled
    Spatial sound using OpenAL enabled
    SPEEX speech compression support enabled
    TIFF image file format disabled
    Video4Linux2 video device support enabled
    FireWire DC1394 video device support enabled
    Theora video codec support enabled
    Swapgroup support for Vrui windows disabled
    Event device support for joysticks disabled
    Vrui will save screenshots in PNG format
    Bluetooth support (for Nintendo Wii controller) enabled
    Support for spatial audio enabled
    USB support (for Razer Hydra and Oculus Rift tracker) enabled
    Support to save screen captures in Ogg/Theora format enabled
    —- Vrui installation configuration —-
    Root installation directory : /home/haggerty/Vrui-3.1
    Header installation root directory : /home/haggerty/Vrui-3.1/include
    Library installation root directory : /home/haggerty/Vrui-3.1/lib/x86_64-linux-gnu
    Executable installation directory : /home/haggerty/Vrui-3.1/bin
    Plug-in installation root directory : /home/haggerty/Vrui-3.1/lib/x86_64-linux-gnu
    Configuration file installation directory : /home/haggerty/Vrui-3.1/etc
    Shared file installation root directory : /home/haggerty/Vrui-3.1/share
    Makefile fragment installation directory : /home/haggerty/Vrui-3.1/share
    Build system installation directory : /home/haggerty/Vrui-3.1/share/make
    pkg-config metafile installation directory: /home/haggerty/Vrui-3.1/lib/x86_64-linux-gnu/pkgconfig
    Documentation installation directory : /home/haggerty/Vrui-3.1/share/doc
    —- End of Vrui configuration options —-
    Linking /home/haggerty/src/Vrui-3.1-004/lib/x86_64-linux-gnu/libUSB.g++-3.so.3.1…
    Linking /home/haggerty/src/Vrui-3.1-004/lib/x86_64-linux-gnu/libIO.g++-3.so.3.1…
    Linking /home/haggerty/src/Vrui-3.1-004/lib/x86_64-linux-gnu/libGLWrappers.g++-3.so.3.1…
    Creating application makefile fragment…
    Creating configuration makefile fragment…
    Creating pkg-config meta data file…
    /usr/bin/ld: cannot find -lGL
    collect2: error: ld returned 1 exit status
    make: *** [/home/haggerty/src/Vrui-3.1-004/lib/x86_64-linux-gnu/libGLWrappers.g++-3.so.3.1] Error 1
    make: *** Waiting for unfinished jobs….
    Build unsuccessful; please fix any reported errors and try again

    I am running on an i7 and with a NVIDIA GTX 870:

    haggerty@haggerty-AR ~ $ inxi -Gx
    Graphics: Card: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0
    Display Server: X.Org 1.17.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
    Resolution: 1280×768@59.9hz
    GLX Renderer: GeForce GTX 970/PCIe/SSE2
    GLX Version: 4.5.0 NVIDIA 367.27 Direct Rendering: Yes
    haggerty@haggerty-AR ~ $

    Any thoughts?

    #102244
    skippy1976uk
    Participant

    It is clearly because it cannot find the GL library:

    /usr/bin/ld: cannot find -lGL

    However, if I list the libraries that ld is using:

    SEARCH_DIR(“/usr/x86_64-linux-gnu/lib64”)
    SEARCH_DIR(“=/usr/local/lib/x86_64-linux-gnu”)
    SEARCH_DIR(“=/usr/local/lib64”)
    SEARCH_DIR(“=/lib/x86_64-linux-gnu”)
    SEARCH_DIR(“=/lib64”)
    SEARCH_DIR(“=/usr/lib/x86_64-linux-gnu”)
    SEARCH_DIR(“=/usr/lib64”)
    SEARCH_DIR(“=/usr/local/lib”)
    SEARCH_DIR(“=/lib”)
    SEARCH_DIR(“=/usr/lib”)

    My initial thought was that the linker was not looking in the correct location. I then searched to see if I could find the GL driver myself:

    haggerty@haggerty-AR ~ $ cd /usr/
    haggerty@haggerty-AR /usr $ find . -name GL* -print
    ./include/GL
    ./lib/python2.7/dist-packages/gi/overrides/GLib.py
    ./lib/python2.7/dist-packages/gi/overrides/GLib.pyc
    ./lib/python3/dist-packages/gi/overrides/GLib.py
    ./lib/python3/dist-packages/gi/overrides/__pycache__/GLib.cpython-34.pyc
    ./lib/girepository-1.0/GL-1.0.typelib
    ./lib/girepository-1.0/GLib-2.0.typelib
    ./share/perl/5.18.2/unicore/lib/Lb/GL.pl

    I am now questioning if I have the GL library installed.

    Any indicators here as to why it cannot find the GL library woudl be most appreciated.

    #102248
    skippy1976uk
    Participant

    Ok, I have solved this. I had many issues installing the drivers, so I managed to get the display working with the latest version from Nvidia (362). However, it appears that the new version of the driver may have caused this build issue.

    I therefore did:

    sudo apt-get purge nvidia*
    service mdm stop

    I then followed the instructions at:

    https://mintguide.org/system/479-install-the-nvidia-driver-352-30-on-linux-mint.html#sel=14:8,14:8

    AFter that all worked!!!!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Comments are closed.