USB Button Solution

Home Forums AR Sandbox Forum USB Button Solution

This topic contains 83 replies, has 21 voices, and was last updated by  ajy00 4 days, 8 hours ago.

Viewing 15 posts - 16 through 30 (of 84 total)
  • Author
    Posts
  • #110853

    liudr
    Participant

    OK, here is my detailed post regarding the USB button box I constructed. Hope it helps:

    My blog post

    #111009

    liudr
    Participant

    Added elevation color mapping adjustment with a knob on the box:

    https://youtu.be/-qsQ5rXE8WI

    #115864

    nensi94
    Participant

    Nice.

    #115953

    idsouvenirbagus
    Participant

    Setelah semua, membeli souvenir adalah bagian tak terpisahkan dari pengalaman liburan yang menyenangkan. Wisatawan juga cenderung mengambil banyak hadiah dan hal baru di rumah untuk teman, kerabat dan rekan kerja. Ini cara yang bagus untuk menunjukkan bahwa Anda telah memikirkannya saat Anda sedang berlibur. Ada beberapa dari kami yang tidak bisa menolak berjalan ke toko suvenir dan keluar dengan sesuatu. Ini dapat terjadi kerajinan dari tembaga banyak terutama jika Anda sedang berlibur bersama anak-anak! Meskipun demikian, souvenir harga kerajinan tembaga tidak selalu terhubung dengan tujuan. Banyak orang mengumpulkan memorabilia peringatan acara khusus seperti pernikahan keluarga kerajaan dan barang dagangan untuk menunjukkan dukungan untuk tim sepak bola atau bola basket favorit favorit mereka, atau bahkan merchandise hiburan yang menampilkan film favorit mereka.

    #115963

    ChrisVeale
    Participant

    Hi Oliver.

    I am looking at setting up this solution, and have managed to pick up the same hardware as in your image, so everything should be the same…

    I have gone through your instructions (which are awesome) and confirmed the product details with an lsusb call, I have added the 69-usb-encoder.rules file as written and I have added the test to the SARndbox.cfg file as written…

    the next statement says “now run as usual” and when you press and hold the buttons the vrui tool selection menu pops up.

    unfortunately when I follow this, the tool selection window does not pop up.

    Can you please let me know what I can do in this scenario? I can still map to keyboard keys, but would really like to get this going.

    I can attach my config files if this is useful…

    Cheers

    #115986

    Oliver Kreylos
    Keymaster

    Are there error messages when starting SARndbox? Check that your modified configuration file is loaded by adding -vruiVerbose to the command line.

    #115987

    ChrisVeale
    Participant

    I will have a check of this thanks Oliver. The sandbox app is still running fine and the other configurations for globalwatertool and the screen maximizing are still running so I think its loading correctly but possibly that specific section is failing…

    Ill have a check now…

    cheers for the pointer in the right direction…

    #115993

    ChrisVeale
    Participant

    Hey Oliver.

    The -vruiVerbose command did the trick thanks heaps I have found the issue, corrected and it now works a treat, off to map it in the inputgraph for further use 🙂

    Cheers again 🙂

    #116023

    sbarringer
    Participant

    Well, I am trying to set up the buttons and I didn’t get far. I ran lsusb and it showed up so I then ran the next step, entered the password and got this message:

    “sudo: pluma: command not found”

    I also tried xed instead of pluma and it brought up a text editor I could paste the info in but then got this message:

    ** (xed:5396): WARNING **: Set document metadata failed: Setting attribute metadata::xed-position not supported

    Thoughts?

    • This reply was modified 3 months, 2 weeks ago by  sbarringer.
    • This reply was modified 3 months, 2 weeks ago by  sbarringer.
    #116026

    sbarringer
    Participant

    I also get:

    (xed:5909): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

    ** (xed:5909): WARNING **: Set document metadata failed: Setting attribute metadata::xed-spell-language not supported

    when I am editing that text file

    #116027

    ChrisVeale
    Participant

    Hey 🙂

    I also had the issue running pluma, I assumed this was because I that isn’t part of the “normal” mint install and I couldn’t be bothered installing that, so I just used xed which worked fine for my purposes. I didn’t have any issues from xed, but I was admin on the box, perhaps check the permissions of running the xed software? you may need to run in admin mode depending on your setup? Alternatively I would look at using or installing another text editor package instead?

    on my install of mint, it came with libre office that you could use at a pinch?

    Just read a few forums and try running xed without using sudo, just a simple xed <<filename>> & should do the trick.

    #116050

    sbarringer
    Participant

    Thanks for your response! I am not sure what exactly I did different than yesterday but I somehow managed to get it working! Now I am trying to figure out if I can get the snow/lava/rain toggle to work. It seems a bit over my head at this point. I might just stop here. lol I am 3D printing housing for the button I created so that’s fun.

    #116057

    ajy00
    Participant

    If you’ve got the first buttons working, you’ll have no trouble with adding new ones for other functions… just follow the script set up and Oliver’s guidance (bless the man for a great piece of work!) on linking to a script … you can use a keyboard link too which is almost essential as an option if you’re working with a group of kids who LOVE buttons….

    I have updated /extended my version of the script (https://arsandbox.ucdavis.edu/forums/topic/usb-button-solution/#post-103570) to include the ice/toxic waste etc from https://arsandbox.ucdavis.edu/forums/users/mkaszuba/ … so have a couple of startup scripts depending on how many/which options I want on the cycle button.

    I’ve now also added a ‘screenshot’ button which means that I can work through a scenario where a group creates a landscape and captures a screenshot to compare with others or against a target topo map… nothing like a bit of competition to keep them at it!

    Shout if you get problems!

    #116058

    sbarringer
    Participant

    Well, the water one was easy since I just push the button and assign it to the water management already existing in the tool selection menu. It’s the steps to adding in the other tools/scripts that I am not sure of.

    #116059

    ajy00
    Participant

    Hi
    Suggest you create a directory under ~/src for your various scripts and custom items, such as ~/src/scripts

    Create a new file something like weather.sh and with your text editor copy the script file from https://arsandbox.ucdavis.edu/forums/topic/usb-button-solution/#post-103570
    Save and then enable execution with chmod a+x ~/src/scripts/weather.sh

    Create new files for each of the conditions in weather.sh in the same directory for example:
    switch-to-water.sh with the syntax
    cp ~/src/scripts/SurfaceAddWaterColor-Water.fs ~ /src/SARndbox-2.5/share/Shaders/SurfacceAddWatercolor.fs
    and again enable execution as above

    You need to ensure you have all appropriate .fs config files saved in the same scripts directory (or appropriately referenced if they’re elsewhere). You can find versions that work from https://arsandbox.ucdavis.edu/forums/users/mkaszuba/

    Once all that is in place, assign the key or button from the Tool Menu, using the option Utility/Script Executor

    Hope that helps!

Viewing 15 posts - 16 through 30 (of 84 total)

You must be logged in to reply to this topic.

Comments are closed.