USB problems with Kinect

Home Forums AR Sandbox Forum USB problems with Kinect

Tagged: , ,

This topic contains 40 replies, has 30 voices, and was last updated by  tusharbose 1 month, 3 weeks ago.

Viewing 11 posts - 31 through 41 (of 41 total)
  • Author
    Posts
  • #114576

    XueYiheng
    Participant

    I met these problem

    terminate called after throwing an instance of ‘std::runtime_error’
    what(): Kinect::Camera::Camera: Less than 0 Kinect camera devices detected

    My Kinect is Version2, and i try to update my Kinect, SARndbox, Vrui to Kinect-3.4, SARndbox-2.4, Vrui-4.4-001.
    It works when I finished step 6 and I could also work RawKinectViewer.

    #114585

    FoleyPhoto1
    Participant

    Hi, I desperately need some help as I am trying to put this Sandbox together for an important trade show and it is not recognizing the Kinect. I am operating on the latest version of Mint, and am using the USB 2.0 slot, and am getting a slow flashing green light (I believe I am using the proper power adapter that I purchased with it). I even bought two of the Kinects and the power adapters in case one failed for some reason. Anyhow, here is the info I am receiving after the lsusb command:

    kevin@AR-Sandbox ~/src/SARndbox-2.4 $ lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 024: ID 04f2:1459 Chicony Electronics Co., Ltd
    Bus 001 Device 005: ID 8087:0aa7 Intel Corp.
    Bus 001 Device 004: ID 0bda:0153 Realtek Semiconductor Corp. Mass Storage Device
    Bus 001 Device 003: ID 0461:4e67 Primax Electronics, Ltd
    Bus 001 Device 026: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
    Bus 001 Device 025: ID 0409:005a NEC Corp. HighSpeed Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    But then, after I enter this command:

    kevin@AR-Sandbox ~/src/SARndbox-2.4 $ sudo /usr/local/bin/KinectUtil getCalib 0

    I get this error:

    Could not download calibration data from Kinect 0

    I tried running this command just to see what happens:

    kevin@AR-Sandbox ~/src/SARndbox-2.4 $ RawKinectViewer -compress 0

    And I get this error:

    Terminated RawKinectViewer due to exception: Kinect::openDirectFrameSource: Less than 0 3D cameras connected to local host

    Does anyone have any ideas? I went through this whole thread and can’t seem to find anyone that is having a similar problem with a fix. Any help or suggestions from the community would be greatly appreciated. Thx

    #115738

    FoleyPhoto1
    Participant

    Hey Rizog,

    What ultimately fixed it for me? I bought 4 USB power supplies to have backups, and the 1st 2 that I tried powered on the Kinect, but for some reason did not function properly. Because I was seeing it power on, I thought the power supply was functioning, but it wasn’t. I even took them all to a Microsoft store to test them.. the 1st 2 were bad, and the 3rd one we tried worked. So, the take away is that even if you are seeing the proper green light flashing, the power supply might be defective. I had 2. Let me know if I can help further.

    #115867

    cdsc
    Participant

    Not sure if this the same issue as listed here but it seems that if i boot the computer with the kinect plugged into any USB 2 or 3 socket that the sandbox program wont launch. i type the usual command and it will just sit there on the terminal window, no errors or anything. like its paused or waiting.

    if i plug the usb in after booting and then type the command to launch the sandbox then it will work correctly. we have sandbox software 2.3 from earlier this year.

    any ideas on what could be causing this? im new to linux so it could be driver/linux related.

    • This reply was modified 1 year, 1 month ago by  cdsc.
    #116047

    inetmktvn16
    Participant

    Not sure if this the same issue as listed here but it seems that if i boot the computer with the kinect plugged into any USB 2 or 3 socket that the sandbox program wont launch. i type the usual command and it will just sit there on the terminal window, no errors or anything. like its paused or waiting.

    if i plug the usb in after booting and then type the command to launch the sandbox then it will work correctly. we have sandbox software 2.3 from earlier this year.

    #116215

    Dylan
    Participant

    I had the 0 Kinect problem. The sandbox application would either not run, or freeze very quickly and throw the error that the Kinect device had disconnected.

    I tried replacing the Kinect power source, and it worked better (1-2 minutes use before freezing).

    I tried plugging the Kinect power source into the wall, rather than a power bar. This improved function also. (2-15 minutes use before freezing.)

    Then I got a crazy idea. I used a “Motomaster Eliminator Powerbox” to power the Kinect. This is a inexpensive car battery booster/inverter combo that throws off dirty power that makes my stereo hum like crazy. In short, now everything works perfectly, no freezing, no problems. I’ve spoken to 2 electricians about why this works, and based on their informal knowledge of the devices, its a bit of a mystery.

    Anyways, hope this helps someone!

    #117979

    boilerEngr
    Participant

    Hi,
    I am working on an AR Sandbox, and I am faced with a strange issue. All of a sudden my dedicated PC is not powering on when the kinect is plugged in via USB and powered on. It only turns on if the kinect is unplugged or powered off. I therefore, have to plug the kinect in after the computer boots up. Any idea what could be causing this? The program still runs fine after the kinect turns on.

    #118544

    andrewdahl
    Participant

    look for similar help-
    this is what I have going on-
    Ubuntu 18.04
    XBOX 360 Kinect model:1414 (have used 2 different ones – same issues)
    I have used the following
    KINECT for WINDOWS HUB model 1637
    IDS 1 Pc Xbox 360 Kinect Sensor USB AV Adapter

    I have gone thru the directions sheet for hooking everything up and am stuck at:
    hooking up the Kinect
    I run lsusb and the kinect does not show up (regardless of which usb port i put it in, 2.0 or 3.0)
    I get no power to the kinect (no lights — nothing)
    I have tried each of the kinects with each of the converters/power sources
    I have used additionally a powered usb hub and still nothing

    one thing that did happen is when i plugged in the usb with the kinect for windows hub- the computer shut down

    could really use some guidance
    thanks

    #118613

    tusharbose
    Participant

    Hey guys!
    I am facing issues with Kinect for Xbox one. I can see the camera field open in the Rawkinect viewer but the depth field is static. Looks like the depth field is not working.

    The software installed are-
    VRUI 4.6-005
    Kinect-3.7
    SARndbox 2.6

    Please help. Need it urgently working.

    #118739

    giuseppe molinario
    Participant

    hi, did you ever figure out the issue? I have the same issue and would LOVE some advice.

    thanks

    #118741

    tusharbose
    Participant

    Hey Hi,
    It got resolved. My system had USB 2.0 and the new Kinect has USB 3.0.

    Regards

Viewing 11 posts - 31 through 41 (of 41 total)

You must be logged in to reply to this topic.

Comments are closed.