Water Simulation Not Running – Runs out of time

Home Forums AR Sandbox Forum Water Simulation Not Running – Runs out of time

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #102861
    crutchre
    Participant

    Howdy!

    I’ve gotten pretty far on my build but can’t get the water sim to run.
    It’s always “Running out of time” (even at a low grid resolution and small steps per frame)

    Here are my specs:
    Ubuntu 16.04 running on Intel Xeon CPU X5670 @ 2.93Ghz x 24 (Old Mac Pro, but Ubuntu is running natively, not emulated)
    AMD Radeon R9 290 (I ran an external PSU to the card)
    Sandbox 2.3, Vrui 4.2, Kinect 3.2

    (Ubuntu says that AMD doesn’t provide drivers for Ubuntu 16.04, so you have to use the provided Hawaii PRO.)

    So is it too slow b/c I’m lower than the recco 3GHz? Or is it b/c I don’t have proprietary graphics card drivers? Or something else?
    (I tried install Ubuntu 14 and putting in the AMD proprietary Catalyst drivers, but that wouldn’t even boot.)

    I would have thought that this rig would be good enough to run at least a slow and at least basic water sim…

    Any ideas appreciated!

    Thanks in advance

    #102862
    Oliver Kreylos
    Keymaster

    The R9 290 should be a fine GPU, so I’m guessing you have driver problems. The reason we recommend Nvidia GPUs over AMDs is AMD’s generally sucky Linux driver quality.

    That said, the “running out of time” error means the water simulation requires more iteration steps than allotted. If you reduce the number of steps via the -ws parameter, you give the simulation even less time to complete. What you can try is reducing the overall water speed via the first option to the -ws parameter, or by adjusting the speed slider in the water control dialog.

    #103127
    ABCottrell
    Participant

    I have a NVIDIA GeForce GTX 970. The water simulation runs but I get the, “Ran out of time by…” code in the terminal over and over and over and etc. I have seen in other posts that your response is, “That means the water simulation ran over its allotted time slot.” What does this mean? I tried your above recommendation by reducing speed but I still get the “Ran out of time by…” code. During installation, I did the step: Update driver. Maybe I need to try this again or do you think I have a bad video card? Thank you.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Comments are closed.